summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-setuptools_36.2.7.bb
diff options
context:
space:
mode:
authorJose Lamego <jose.a.lamego@linux.intel.com>2017-08-09 15:01:04 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-16 00:03:14 +0100
commitb13df74256a9fce5991d09ab3916f96bedf9be2b (patch)
tree4d4284e1352349e977a87bb2fd0a3827d9133dfe /meta/recipes-devtools/python/python3-setuptools_36.2.7.bb
parente31ba8f1228d30d41a6b83aa3cc07051e9ff3872 (diff)
downloadpoky-b13df74256a9fce5991d09ab3916f96bedf9be2b.tar.gz
python*-setuptools: update to 36.2.7
Both python-setuptools and python3-setuptools must be updated to latest stable release. These changes were tested on qemu with core-image-minimal (From OE-Core rev: 147d9260eb79edfdf7a91fb8bc3d915f141dc685) Signed-off-by: Jose Lamego <jose.a.lamego@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-setuptools_36.2.7.bb')
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_36.2.7.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools_36.2.7.bb b/meta/recipes-devtools/python/python3-setuptools_36.2.7.bb
new file mode 100644
index 0000000000..65af6f0dad
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-setuptools_36.2.7.bb
@@ -0,0 +1,37 @@
1require python-setuptools.inc
2
3DEPENDS += "python3"
4DEPENDS_class-native += "python3-native"
5
6inherit distutils3
7
8DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}"
9
10# The installer puts the wrong path in the setuptools.pth file. Correct it.
11do_install_append() {
12 rm ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
13 mv ${D}${bindir}/easy_install ${D}${bindir}/easy3_install
14 echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
15}
16
17RDEPENDS_${PN} = "\
18 python3-distutils \
19 python3-compression \
20"
21RDEPENDS_${PN}_class-target = "\
22 python3-ctypes \
23 python3-distutils \
24 python3-email \
25 python3-importlib \
26 python3-numbers \
27 python3-compression \
28 python3-shell \
29 python3-subprocess \
30 python3-textutils \
31 python3-pkgutil \
32 python3-threading \
33 python3-misc \
34 python3-unittest \
35 python3-xml \
36"
37BBCLASSEXTEND = "native"