summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-setuptools_32.1.1.bb
diff options
context:
space:
mode:
authorEdwin Plauchu <edwin.plauchu.camacho@linux.intel.com>2017-01-12 14:52:13 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-19 22:47:21 +0000
commitda76cda28f45f49b267c6f1b41df165914819d7f (patch)
tree1480b5f35692cd6e61573821153893da01ce6fc5 /meta/recipes-devtools/python/python3-setuptools_32.1.1.bb
parentb0fc05ea492beddeb444efae8a49805bf1e926e0 (diff)
downloadpoky-da76cda28f45f49b267c6f1b41df165914819d7f.tar.gz
python3-setuptools: upgrade to 31.1.1
It is a simultaneous upgrade for python 2 and 3 over setuptools. (From OE-Core rev: e37e023da9833fc6d17a8a57554aaf986b4e8d56) Signed-off-by: Edwin Plauchu <edwin.plauchu.camacho@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-setuptools_32.1.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_32.1.1.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools_32.1.1.bb b/meta/recipes-devtools/python/python3-setuptools_32.1.1.bb
new file mode 100644
index 0000000000..65af6f0dad
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-setuptools_32.1.1.bb
@@ -0,0 +1,37 @@
1require python-setuptools.inc
2
3DEPENDS += "python3"
4DEPENDS_class-native += "python3-native"
5
6inherit distutils3
7
8DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}"
9
10# The installer puts the wrong path in the setuptools.pth file. Correct it.
11do_install_append() {
12 rm ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
13 mv ${D}${bindir}/easy_install ${D}${bindir}/easy3_install
14 echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
15}
16
17RDEPENDS_${PN} = "\
18 python3-distutils \
19 python3-compression \
20"
21RDEPENDS_${PN}_class-target = "\
22 python3-ctypes \
23 python3-distutils \
24 python3-email \
25 python3-importlib \
26 python3-numbers \
27 python3-compression \
28 python3-shell \
29 python3-subprocess \
30 python3-textutils \
31 python3-pkgutil \
32 python3-threading \
33 python3-misc \
34 python3-unittest \
35 python3-xml \
36"
37BBCLASSEXTEND = "native"