summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-setuptools_18.2.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2015-12-04 15:35:38 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-12-12 23:42:54 +0000
commitdec8d20c290d68c1b741a818e4bc56c51a9da5f4 (patch)
tree6b32219bedb5bc4f8fcd8a261ade5497069a2902 /meta/recipes-devtools/python/python3-setuptools_18.2.bb
parentb3535e24361a076f21abfd3817254e328031e17b (diff)
downloadpoky-dec8d20c290d68c1b741a818e4bc56c51a9da5f4.tar.gz
python-setuptools: update to 18.7.1
(From OE-Core rev: 3df78d4850e06ba4febd638bf52ee3b2927c5094) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-setuptools_18.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-setuptools_18.2.bb57
1 files changed, 0 insertions, 57 deletions
diff --git a/meta/recipes-devtools/python/python3-setuptools_18.2.bb b/meta/recipes-devtools/python/python3-setuptools_18.2.bb
deleted file mode 100644
index 5687e308b8..0000000000
--- a/meta/recipes-devtools/python/python3-setuptools_18.2.bb
+++ /dev/null
@@ -1,57 +0,0 @@
1SUMMARY = "Download, build, install, upgrade, and uninstall Python packages"
2HOMEPAGE = "http://packages.python.org/setuptools"
3SECTION = "devel/python"
4LICENSE = "PSF"
5LIC_FILES_CHKSUM = "file://setup.py;beginline=78;endline=78;md5=8a314270dd7a8dbca741775415f1716e"
6
7SRCNAME = "setuptools"
8DEPENDS += "python3"
9DEPENDS_class-native += "python3-native"
10
11SRC_URI = " \
12 http://pypi.python.org/packages/source/s/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
13"
14SRC_URI[md5sum] = "52b4e48939ef311d7204f8fe940764f4"
15SRC_URI[sha256sum] = "0994a58df27ea5dc523782a601357a2198b7493dcc99a30d51827a23585b5b1d"
16
17UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/setuptools"
18
19S = "${WORKDIR}/${SRCNAME}-${PV}"
20
21inherit distutils3
22
23DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages"
24
25do_install_prepend() {
26 install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
27}
28#
29# The installer puts the wrong path in the setuptools.pth file. Correct it.
30#
31do_install_append() {
32 rm ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
33 mv ${D}${bindir}/easy_install ${D}${bindir}/easy3_install
34 echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth
35}
36
37RDEPENDS_${PN} = "\
38 python3-distutils \
39 python3-compression \
40"
41RDEPENDS_${PN}_class-target = "\
42 python3-ctypes \
43 python3-distutils \
44 python3-email \
45 python3-importlib \
46 python3-numbers \
47 python3-compression \
48 python3-shell \
49 python3-subprocess \
50 python3-textutils \
51 python3-pkgutil \
52 python3-threading \
53 python3-misc \
54 python3-unittest \
55 python3-xml \
56"
57BBCLASSEXTEND = "native"