summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-semantic-version_2.10.0.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2022-05-30 14:22:51 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-05-31 15:24:18 +0100
commitefd43290caa6514e275f8a9afbbda2973ddb775b (patch)
treebede731701419a0026b3ed79f7c48556c06951ad /meta/recipes-devtools/python/python3-semantic-version_2.10.0.bb
parentd81ed52c78346e9f87652fe715e1301da6c7797b (diff)
downloadpoky-efd43290caa6514e275f8a9afbbda2973ddb775b.tar.gz
python3-semantic-version: upgrade 2.9.0 -> 2.10.0
Add dependence python3-pkg-resources Changelog: ========== Ensure sorting a collection of versions is always stable, even with build metadata. (From OE-Core rev: 70d68ca81fd92140367a832d7fb30963a2cac5c1) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-semantic-version_2.10.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-semantic-version_2.10.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-semantic-version_2.10.0.bb b/meta/recipes-devtools/python/python3-semantic-version_2.10.0.bb
new file mode 100644
index 0000000000..0a24ca9ebc
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-semantic-version_2.10.0.bb
@@ -0,0 +1,18 @@
1SUMMARY = "A library implementing the 'SemVer' scheme."
2DESCRIPTION = "Semantic version comparison for Python (see http://semver.org/)"
3HOMEPAGE = "https://github.com/rbarrois/python-semanticversion"
4LICENSE = "BSD-2-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=4fb31e3c1c7eeb8b5e8c07657cdd54e2"
6
7SRC_URI[sha256sum] = "bdabb6d336998cbb378d4b9db3a4b56a1e3235701dc05ea2690d9a997ed5041c"
8
9PYPI_PACKAGE = "semantic_version"
10inherit pypi setuptools3
11
12RDEPENDS:${PN} += " \
13 ${PYTHON_PN}-pkg-resources \
14"
15
16BBCLASSEXTEND = "native nativesdk"
17
18UPSTREAM_CHECK_REGEX = "/semantic-version/(?P<pver>(\d+[\.\-_]*)+)/"