diff options
author | Tim Orling <timothy.t.orling@linux.intel.com> | 2020-02-24 20:21:42 -0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2020-02-28 23:11:28 +0000 |
commit | 8bc346da036683eb3efc0820ddb68c8f2613fbe0 (patch) | |
tree | 6a23bcf9d228a204d3513a7c210c816b0d3f1941 /meta/recipes-devtools/python/python3-scons_3.1.2.bb | |
parent | 035ca9ea653aeaa538bdfdb3fa9a9960e4f23d9e (diff) | |
download | poky-8bc346da036683eb3efc0820ddb68c8f2613fbe0.tar.gz |
python3-scons{-native}: upgrade 3.1.1 -> 3.1.2
THis release is a mix of improvements and fixes:
https://github.com/SCons/scons/blob/3.1.2/src/RELEASE.txt
* Changed to inherit pypi rather than relying on SOURCEFORGE_MIRROR.
* Add SRC_URI for LICENSE file (not included in pypi tarball).
* Make it more obvious that RDEPENDS are for class-target and
drop empty RDEPENDS from -native
* python3-scons-native now DEPENDS on python3-setuptools-native
* Tested with core-image-base + packagegroup-core-buildessential
with "scons" oe-selftest via testimage.
* Tested build of "serf" (which uses python3-scons-native via the
scons.bbclass).
License-Update: Added "MIT License" text, updated copyright years
(From OE-Core rev: 44b46ae6c65448901477def57a45d5a4ecc2d246)
Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-scons_3.1.2.bb')
-rw-r--r-- | meta/recipes-devtools/python/python3-scons_3.1.2.bb | 33 |
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-scons_3.1.2.bb b/meta/recipes-devtools/python/python3-scons_3.1.2.bb new file mode 100644 index 0000000000..aa7a2a8300 --- /dev/null +++ b/meta/recipes-devtools/python/python3-scons_3.1.2.bb | |||
@@ -0,0 +1,33 @@ | |||
1 | SUMMARY = "Software Construction tool (make/autotools replacement)" | ||
2 | SECTION = "devel/python" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://${WORKDIR}/LICENSE;md5=e14e1b33428df24a40a782ae142785d0" | ||
5 | |||
6 | # pypi package does not have a valid license file | ||
7 | SRC_URI += "https://raw.githubusercontent.com/SCons/scons/${PV}/LICENSE;name=license" | ||
8 | |||
9 | SRC_URI[md5sum] = "f9c4ad06dcf1427be95472eaf380c81a" | ||
10 | SRC_URI[sha256sum] = "8aaa483c303efeb678e6f7c776c8444a482f8ddc3ad891f8b6cdd35264da9a1f" | ||
11 | SRC_URI[license.md5sum] = "e14e1b33428df24a40a782ae142785d0" | ||
12 | SRC_URI[license.sha256sum] = "72ed889165fb28378cadac14552be4a959f1ebab6b148abb5dd2b49712c3c6f6" | ||
13 | |||
14 | S = "${WORKDIR}/scons-${PV}" | ||
15 | |||
16 | UPSTREAM_CHECK_URI = "http://scons.org/pages/download.html" | ||
17 | UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar" | ||
18 | |||
19 | inherit pypi setuptools3 | ||
20 | |||
21 | do_install_prepend() { | ||
22 | sed -i -e "1s,#!.*python.*,#!${USRBINPATH}/env python3," ${S}/script/* | ||
23 | } | ||
24 | |||
25 | RDEPENDS_${PN}_class-target = "\ | ||
26 | python3-core \ | ||
27 | python3-fcntl \ | ||
28 | python3-io \ | ||
29 | python3-json \ | ||
30 | python3-shell \ | ||
31 | python3-pickle \ | ||
32 | python3-pprint \ | ||
33 | " | ||