summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-ruamel-yaml_0.17.35.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-10-13 17:10:17 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-10-19 13:38:57 +0100
commit708d11b23c15015ee4d0b721f3c8d255d4b5c305 (patch)
treed8c84acc20344efbdc5a696d0cff4244ecaa594d /meta/recipes-devtools/python/python3-ruamel-yaml_0.17.35.bb
parent1802e9244b1fa1573c33b5349c46d81e40c71dd7 (diff)
downloadpoky-708d11b23c15015ee4d0b721f3c8d255d4b5c305.tar.gz
python3-ruamel-yaml: upgrade 0.17.32 -> 0.17.35
Changelog: ============== - support for loading dataclasses with 'InitVar' variables (some special coding was necessary to get the, unexecpected, default value in the corresponding instance attribute in [this question](https://stackoverflow.com/q/77228378/1307905)) - Python 3.12 also loads C version when using 'typ='safe'' - added 'flow_seq_start', 'flow_seq_end', 'flow_seq_separator', 'flow_map_start', 'flow_map_end', 'flow_map_separator' **class** attributes to the 'Emitter' class so flow style output can more easily be influenced (From OE-Core rev: 0151bba91387559852c27e044d6e58c3a53d26d5) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-ruamel-yaml_0.17.35.bb')
-rw-r--r--meta/recipes-devtools/python/python3-ruamel-yaml_0.17.35.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-ruamel-yaml_0.17.35.bb b/meta/recipes-devtools/python/python3-ruamel-yaml_0.17.35.bb
new file mode 100644
index 0000000000..1760fec7ee
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-ruamel-yaml_0.17.35.bb
@@ -0,0 +1,23 @@
1SUMMARY = "YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order."
2HOMEPAGE = "https://pypi.org/project/ruamel.yaml/"
3
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=0e5f41db57c3a8d3584b450d35985ad1"
6
7PYPI_PACKAGE = "ruamel.yaml"
8
9inherit pypi setuptools3
10
11SRC_URI[sha256sum] = "801046a9caacb1b43acc118969b49b96b65e8847f29029563b29ac61d02db61b"
12
13RDEPENDS:${PN} += "\
14 ${PYTHON_PN}-shell \
15 ${PYTHON_PN}-datetime \
16 ${PYTHON_PN}-netclient \
17"
18
19do_install:prepend() {
20 export RUAMEL_NO_PIP_INSTALL_CHECK=1
21}
22
23BBCLASSEXTEND = "native nativesdk"