summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-ruamel-yaml_0.17.21.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2022-02-15 15:36:46 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-02-16 09:46:29 +0000
commit20dfd9a646ecee57be608e2562654765808dbc60 (patch)
tree8bf04d66b847c3dfccae3103703a00b048c43c2f /meta/recipes-devtools/python/python3-ruamel-yaml_0.17.21.bb
parent083623bdd356daa3e5000f261464b73ec8243f91 (diff)
downloadpoky-20dfd9a646ecee57be608e2562654765808dbc60.tar.gz
python3-ruamel-yaml: upgrade 0.17.20 -> 0.17.21
Changelog: ========= - fix bug in calling '.compose()' method with 'pathlib.Path' instance. (From OE-Core rev: 1f5f7cdf998cfb5f5635953ab862728a08192778) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-ruamel-yaml_0.17.21.bb')
-rw-r--r--meta/recipes-devtools/python/python3-ruamel-yaml_0.17.21.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-ruamel-yaml_0.17.21.bb b/meta/recipes-devtools/python/python3-ruamel-yaml_0.17.21.bb
new file mode 100644
index 0000000000..7d65c4c2d8
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-ruamel-yaml_0.17.21.bb
@@ -0,0 +1,24 @@
1SUMMARY = "YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order."
2HOMEPAGE = "https://pypi.org/project/ruamel.yaml/"
3AUTHOR = "Anthon van der Neut"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=034154b7344d15438bc5ed5ee9cc075f"
7
8PYPI_PACKAGE = "ruamel.yaml"
9
10inherit pypi setuptools3
11
12SRC_URI[sha256sum] = "8b7ce697a2f212752a35c1ac414471dc16c424c9573be4926b56ff3f5d23b7af"
13
14RDEPENDS:${PN} += "\
15 ${PYTHON_PN}-shell \
16 ${PYTHON_PN}-datetime \
17 ${PYTHON_PN}-netclient \
18"
19
20do_install:prepend() {
21 export RUAMEL_NO_PIP_INSTALL_CHECK=1
22}
23
24BBCLASSEXTEND = "native nativesdk"