summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-requests_2.31.0.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-06-01 17:03:34 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-06-02 15:16:36 +0100
commit8172d3f70c97ceed5eb99b08c3cc3328759924ab (patch)
treee51f9ec369aaaaa6daa74a73585e3bf4be243cb1 /meta/recipes-devtools/python/python3-requests_2.31.0.bb
parent2e4fda8324af27121222f91e22f1e617a5088c06 (diff)
downloadpoky-8172d3f70c97ceed5eb99b08c3cc3328759924ab.tar.gz
python3-requests: upgrade 2.30.0 -> 2.31.0
Changelog: ========== Versions of Requests between v2.3.0 and v2.30.0 are vulnerable to potential forwarding of Proxy-Authorization headers to destination servers when following HTTPS redirects. (From OE-Core rev: 97bdf3baf6e612757863e05e84e3b79c4330d27b) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-requests_2.31.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-requests_2.31.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-requests_2.31.0.bb b/meta/recipes-devtools/python/python3-requests_2.31.0.bb
new file mode 100644
index 0000000000..7ac43f2eb9
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-requests_2.31.0.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Python HTTP for Humans."
2HOMEPAGE = "http://python-requests.org"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=34400b68072d710fecd0a2940a0d1658"
5
6SRC_URI[sha256sum] = "942c5a758f98d790eaed1a29cb6eefc7ffb0d1cf7af05c3d2791656dbd6ad1e1"
7
8inherit pypi setuptools3
9
10RDEPENDS:${PN} += " \
11 ${PYTHON_PN}-email \
12 ${PYTHON_PN}-json \
13 ${PYTHON_PN}-ndg-httpsclient \
14 ${PYTHON_PN}-netserver \
15 ${PYTHON_PN}-pyasn1 \
16 ${PYTHON_PN}-pyopenssl \
17 ${PYTHON_PN}-pysocks \
18 ${PYTHON_PN}-urllib3 \
19 ${PYTHON_PN}-chardet \
20 ${PYTHON_PN}-idna \
21 ${PYTHON_PN}-compression \
22"
23
24CVE_PRODUCT = "requests"
25
26BBCLASSEXTEND = "native nativesdk"