summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pytz_2024.1.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-02-28 15:32:44 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-03-01 09:28:52 +0000
commit376dc30276c2f3841f1a4e3e9bfe7b72f82a62e7 (patch)
tree04ca9a67a21032ea993e9532ee1ba61762b520f0 /meta/recipes-devtools/python/python3-pytz_2024.1.bb
parent9a5c2f900ebef32e198e83ee9131ea8ec5b26691 (diff)
downloadpoky-376dc30276c2f3841f1a4e3e9bfe7b72f82a62e7.tar.gz
python3-pytz: upgrade 2023.4 -> 2024.1
(From OE-Core rev: 17b6104583bb6122ca051dcc004120c24b5579cf) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pytz_2024.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pytz_2024.1.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pytz_2024.1.bb b/meta/recipes-devtools/python/python3-pytz_2024.1.bb
new file mode 100644
index 0000000000..158e800fed
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pytz_2024.1.bb
@@ -0,0 +1,36 @@
1SUMMARY = "World timezone definitions, modern and historical"
2HOMEPAGE = "http://pythonhosted.org/pytz"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=1a67fc46c1b596cce5d21209bbe75999"
5
6inherit pypi setuptools3 ptest
7
8SRC_URI[sha256sum] = "2a29735ea9c18baf14b448846bde5a48030ed267578472d8955cd0e7443a9812"
9
10RDEPENDS:${PN}:class-target += "\
11 python3-datetime \
12 python3-doctest \
13 python3-io \
14 python3-pickle \
15 python3-pprint \
16 python3-threading \
17"
18
19BBCLASSEXTEND = "native nativesdk"
20
21SRC_URI += " \
22 file://run-ptest \
23"
24
25RDEPENDS:${PN}-ptest += " \
26 python3-pytest \
27 python3-unittest-automake-output \
28"
29
30do_install_ptest() {
31 install -d ${D}${PTEST_PATH}/pytz
32 install -d ${D}${PTEST_PATH}/pytz/tests
33 cp -rf ${S}/pytz/tests/* ${D}${PTEST_PATH}/pytz/tests/
34 cp -f ${S}/README.rst ${D}${PTEST_PATH}/
35
36}