summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pyrsistent_0.20.0.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-11-03 15:21:26 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-11-05 11:28:41 +0000
commitef5a8317f4caac478793fa70e6f812c95b212d1e (patch)
tree24ade3d08c15b938edd92c7063d34605a89bbbb3 /meta/recipes-devtools/python/python3-pyrsistent_0.20.0.bb
parentd47399d380fe81dad824a6ffb23dda1daf82fac9 (diff)
downloadpoky-ef5a8317f4caac478793fa70e6f812c95b212d1e.tar.gz
python3-pyrsistent: upgrade 0.19.3 -> 0.20.0
Changelog: =========== * Fix #245, never introduce new nodes during discard. * Fix #268, do not rely on well implemented __ne__ for keys in pmaps, instead do explicit inversion of equality comparison when checking for inequality. * Officially support Python 3.12. * Officially drop support for Python 3.7. * Fix #273, build more types of wheels. Thanks @jams2 for this! * Fix #282, add generic types to types. Thanks @lukasK9999 for this! * Fix #281, defaultdict can now be frozen. NB! This is a backwards incompatible fix since defaultdict was not previously frozen. License-Update: Copyright year updated to 2023. (From OE-Core rev: 10d96b7880c81575f1b5d4b3c920229cee71c43a) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pyrsistent_0.20.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pyrsistent_0.20.0.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pyrsistent_0.20.0.bb b/meta/recipes-devtools/python/python3-pyrsistent_0.20.0.bb
new file mode 100644
index 0000000000..9661f1474e
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pyrsistent_0.20.0.bb
@@ -0,0 +1,14 @@
1SUMMARY = "Persistent/Immutable/Functional data structures for Python"
2HOMEPAGE = "https://github.com/tobgu/pyrsistent"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.mit;md5=f798dc4222a29fea881fa998cdf4a8c8"
5
6SRC_URI[sha256sum] = "4c48f78f62ab596c679086084d0dd13254ae4f3d6c72a83ffdf5ebdef8f265a4"
7
8inherit pypi python_setuptools_build_meta
9
10RDEPENDS:${PN} += " \
11 ${PYTHON_PN}-numbers \
12"
13
14BBCLASSEXTEND = "native nativesdk"