summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pyopenssl_23.3.0.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-11-03 15:40:05 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-11-05 11:28:44 +0000
commita96b67643adc01d0e3971c4efc8afe93cdfdf5b9 (patch)
tree0841e9f1ded2253f8cb0aa1f643bf83a204ea424 /meta/recipes-devtools/python/python3-pyopenssl_23.3.0.bb
parent9e9edea60fdc5d40e79e6920d6e57ea2284eb6f3 (diff)
downloadpoky-a96b67643adc01d0e3971c4efc8afe93cdfdf5b9.tar.gz
python3-pyopenssl: upgrade 23.2.0 -> 23.3.0
Changelog: ============ -Dropped support for Python 3.6. -The minimum cryptography version is now 41.0.5. -Removed OpenSSL.crypto.loads_pkcs7 and OpenSSL.crypto.loads_pkcs12 which had been deprecated for 3 years. -Added OpenSSL.SSL.OP_LEGACY_SERVER_CONNECT to allow legacy insecure renegotiation between OpenSSL and unpatched servers. #1234. -Changed OpenSSL.crypto.X509Store.add_crl to also accept cryptography's x509.CertificateRevocationList arguments in addition to the now deprecated OpenSSL.crypto.CRL arguments. -Fixed test_set_default_verify_paths test so that it is skipped if no network connection is available. (From OE-Core rev: 674e69b5ec58bc81d475a0726d982df2cf86c6e0) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pyopenssl_23.3.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pyopenssl_23.3.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pyopenssl_23.3.0.bb b/meta/recipes-devtools/python/python3-pyopenssl_23.3.0.bb
new file mode 100644
index 0000000000..cdcae48d60
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pyopenssl_23.3.0.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Simple Python wrapper around the OpenSSL library"
2HOMEPAGE = "https://pyopenssl.org/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
6DEPENDS += "openssl ${PYTHON_PN}-cryptography"
7
8SRC_URI[sha256sum] = "6b2cba5cc46e822750ec3e5a81ee12819850b11303630d575e98108a079c2b12"
9
10PYPI_PACKAGE = "pyOpenSSL"
11inherit pypi setuptools3
12
13PACKAGES =+ "${PN}-tests"
14FILES:${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"
15
16RDEPENDS:${PN}:class-target = " \
17 ${PYTHON_PN}-cryptography \
18 ${PYTHON_PN}-six \
19 ${PYTHON_PN}-threading \
20"
21RDEPENDS:${PN}-tests = "${PN}"
22
23BBCLASSEXTEND = "native nativesdk"