summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pycairo_1.10.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-06-02 12:25:52 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-03 13:13:27 +0100
commit4672ffabc6bc1ef101e015e715e7ebb0d7e58c0f (patch)
treeb075eaf997b2f574a45ee7e1d099e96536cf78ec /meta/recipes-devtools/python/python3-pycairo_1.10.0.bb
parenta8d85cf116f40e183bf9a9579ed7d27751f6a501 (diff)
downloadpoky-4672ffabc6bc1ef101e015e715e7ebb0d7e58c0f.tar.gz
python-pycairo: move to Python 3
The Python 3 version comes in a separate tarball, and is relicensed under LGPLv3: http://cairographics.org/pycairo/ (From OE-Core rev: bfd62071befd0f20597cf9c62c281fb6e815bd2e) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pycairo_1.10.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pycairo_1.10.0.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pycairo_1.10.0.bb b/meta/recipes-devtools/python/python3-pycairo_1.10.0.bb
new file mode 100644
index 0000000000..f9031b3bca
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pycairo_1.10.0.bb
@@ -0,0 +1,40 @@
1SUMMARY = "Python bindings for the Cairo canvas library"
2HOMEPAGE = "http://cairographics.org/pycairo"
3BUGTRACKER = "http://bugs.freedesktop.org"
4SECTION = "python-devel"
5LICENSE = "LGPLv3"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
7 file://COPYING.LESSER;md5=e6a600fd5e1d9cbde2d983680233ad02"
8
9# cairo >= 1.8.8
10DEPENDS = "cairo"
11PR = "r2"
12
13SRC_URI = "http://cairographics.org/releases/pycairo-${PV}.tar.bz2"
14
15SRC_URI[md5sum] = "e6fd3f2f1e6a72e0db0868c4985669c5"
16SRC_URI[sha256sum] = "9aa4078e7eb5be583aeabbe8d87172797717f95e8c4338f0d4a17b683a7253be"
17
18S = "${WORKDIR}/pycairo-${PV}"
19
20inherit distutils3 pkgconfig
21
22BBCLASSEXTEND = "native"
23
24do_configure() {
25 PYTHON=${PYTHON} ./waf configure --prefix=${D}${prefix} --libdir=${D}${libdir}
26}
27
28do_compile() {
29 ./waf build ${PARALLEL_MAKE}
30}
31
32do_install() {
33 ./waf install
34 sed \
35 -e 's:@prefix@:${prefix}:' \
36 -e 's:@VERSION@:${PV}:' \
37 -e 's:@includedir@:${includedir}:' \
38 py3cairo.pc.in > py3cairo.pc
39 install -m 0644 py3cairo.pc ${D}${libdir}/pkgconfig/
40}