summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-psutil_5.9.2.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2022-09-15 10:29:42 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-09-17 07:47:08 +0100
commit64d021e26fb92cf640791c9694532e7423fb94fc (patch)
tree7010a519dfd5483d437a982c0a01b93e724bcad4 /meta/recipes-devtools/python/python3-psutil_5.9.2.bb
parent2f4eb09338bf6bf00c290b496a40b9bf1bef10ce (diff)
downloadpoky-64d021e26fb92cf640791c9694532e7423fb94fc.tar.gz
python3-psutil: upgrade 5.9.1 -> 5.9.2
(From OE-Core rev: 9109fd6ae40c23820c66c8f388138bc3da633335) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-psutil_5.9.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-psutil_5.9.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-psutil_5.9.2.bb b/meta/recipes-devtools/python/python3-psutil_5.9.2.bb
new file mode 100644
index 0000000000..5b31014657
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-psutil_5.9.2.bb
@@ -0,0 +1,27 @@
1SUMMARY = "A cross-platform process and system utilities module for Python"
2LICENSE = "BSD-3-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=e35fd9f271d19d5f742f20a9d1f8bb8b"
4HOMEPAGE = "https://pypi.org/project/psutil/"
5
6SRC_URI[sha256sum] = "feb861a10b6c3bb00701063b37e4afc754f8217f0f09c42280586bd6ac712b5c"
7
8inherit pypi setuptools3
9
10PACKAGES =+ "${PN}-tests"
11
12FILES:${PN}-tests += " \
13 ${PYTHON_SITEPACKAGES_DIR}/psutil/test* \
14 ${PYTHON_SITEPACKAGES_DIR}/psutil/__pycache__/test* \
15"
16
17
18RDEPENDS:${PN} += " \
19 ${PYTHON_PN}-shell \
20 ${PYTHON_PN}-threading \
21 ${PYTHON_PN}-xml \
22 ${PYTHON_PN}-netclient \
23 ${PYTHON_PN}-ctypes \
24 ${PYTHON_PN}-resource \
25"
26
27BBCLASSEXTEND = "native nativesdk"