diff options
author | Tim Orling <ticotimo@gmail.com> | 2021-08-25 20:28:05 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2021-08-27 11:54:33 +0100 |
commit | df27e9928ca5bc6f7984bcaf5e804ab02ebe7d96 (patch) | |
tree | 4bd3b5df47e61ad29bf171c624665ac8c497a002 /meta/recipes-devtools/python/python3-pluggy_1.0.0.bb | |
parent | 881bafcbb98af55d2f3e5973d514d12c44d5a115 (diff) | |
download | poky-df27e9928ca5bc6f7984bcaf5e804ab02ebe7d96.tar.gz |
python3-pluggy: upgrade 0.13.1 -> 1.0.0
* All ptests pass on qemux86-64
pluggy 1.0.0 (2021-08-25)
Deprecations and Removals
#116: Remove deprecated implprefix support. Decorate hook
implementations using an instance of HookimplMarker instead.
The deprecation was announced in release 0.7.0.
#120: Remove the deprecated proc argument to call_historic. Use
result_callback instead, which has the same behavior. The
deprecation was announced in release 0.7.0.
#265: Remove the _Result.result property. Use _Result.get_result()
instead. Note that unlike result, get_result() raises the
exception if the hook raised. The deprecation was announced in release
0.6.0.
#267: Remove official support for Python 3.4.
#272: Dropped support for Python 2. Continue to use pluggy 0.13.x
for Python 2 support.
#308: Remove official support for Python 3.5.
#313: The internal pluggy.callers, pluggy.manager and pluggy.hooks
are now explicitly marked private by a _ prefix (e.g.
pluggy._callers). Only API exported by the top-level pluggy module is
considered public.
#59: Remove legacy __multicall__ recursive hook calling system. The
deprecation was announced in release 0.5.0.
Features
#282: When registering a hookimpl which is declared as
hookwrapper=True but whose function is not a generator
function, a PluggyValidationError exception is now raised.
Previously this problem would cause an error only later, when
calling the hook.
In the unlikely case that you have a hookwrapper that returns a
generator instead of yielding directly, for example:
def my_hook_real_implementation(arg):
print("before")
yield
print("after")
@hookimpl(hookwrapper=True)
def my_hook(arg):
return my_hook_implementation(arg)
change it to use yield from instead:
@hookimpl(hookwrapper=True)
def my_hook(arg):
yield from my_hook_implementation(arg)
#309: Add official support for Python 3.9.
(From OE-Core rev: 4cb9623933e3daeb754c06263167be61100f6c0a)
Signed-off-by: Tim Orling <timothy.t.orling@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pluggy_1.0.0.bb')
-rw-r--r-- | meta/recipes-devtools/python/python3-pluggy_1.0.0.bb | 26 |
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pluggy_1.0.0.bb b/meta/recipes-devtools/python/python3-pluggy_1.0.0.bb new file mode 100644 index 0000000000..14a7ccb0b0 --- /dev/null +++ b/meta/recipes-devtools/python/python3-pluggy_1.0.0.bb | |||
@@ -0,0 +1,26 @@ | |||
1 | SUMMARY = "Plugin and hook calling mechanisms for python" | ||
2 | HOMEPAGE = "https://github.com/pytest-dev/pluggy" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1c8206d16fd5cc02fa9b0bb98955e5c2" | ||
5 | |||
6 | SRC_URI[sha256sum] = "4224373bacce55f955a878bf9cfa763c1e360858e330072059e10bad68531159" | ||
7 | |||
8 | DEPENDS += "${PYTHON_PN}-setuptools-scm-native" | ||
9 | RDEPENDS:${PN} += "${PYTHON_PN}-importlib-metadata \ | ||
10 | ${PYTHON_PN}-more-itertools \ | ||
11 | " | ||
12 | |||
13 | inherit pypi ptest setuptools3 | ||
14 | |||
15 | SRC_URI += " \ | ||
16 | file://run-ptest \ | ||
17 | " | ||
18 | |||
19 | RDEPENDS:${PN}-ptest += " \ | ||
20 | ${PYTHON_PN}-pytest \ | ||
21 | " | ||
22 | |||
23 | do_install_ptest() { | ||
24 | install -d ${D}${PTEST_PATH}/testing | ||
25 | cp -rf ${S}/testing/* ${D}${PTEST_PATH}/testing/ | ||
26 | } | ||