diff options
author | Juro Bystricky <juro.bystricky@intel.com> | 2017-03-15 13:17:26 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2017-03-16 22:11:32 +0000 |
commit | 8fc9d8e9a6321136ff1dd5f8ffc3d489ba0d4643 (patch) | |
tree | 152bb92a35df91c75b04349421b1a5443c6d77cf /meta/recipes-devtools/python/python3-pip_9.0.1.bb | |
parent | 68e57fa7480fb7df0e7504df4ed75f2b4719786e (diff) | |
download | poky-8fc9d8e9a6321136ff1dd5f8ffc3d489ba0d4643.tar.gz |
python3-pip: support native builds
Add native pip3 support.
[YOCTO#11049]
[YOCTO#11022]
(From OE-Core rev: cb2073658305b605cccc60439b62c1dc515d9a8d)
Signed-off-by: Juro Bystricky <juro.bystricky@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pip_9.0.1.bb')
-rw-r--r-- | meta/recipes-devtools/python/python3-pip_9.0.1.bb | 7 |
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pip_9.0.1.bb b/meta/recipes-devtools/python/python3-pip_9.0.1.bb index b6dbb6e5f2..4456b9b1b1 100644 --- a/meta/recipes-devtools/python/python3-pip_9.0.1.bb +++ b/meta/recipes-devtools/python/python3-pip_9.0.1.bb | |||
@@ -34,6 +34,11 @@ do_install_append() { | |||
34 | 34 | ||
35 | # Installed eggs need to be passed directly to the interpreter via a pth file | 35 | # Installed eggs need to be passed directly to the interpreter via a pth file |
36 | echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}-${PV}.pth | 36 | echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}-${PV}.pth |
37 | |||
38 | # Make sure we use /usr/bin/env python3 | ||
39 | for PYTHSCRIPT in `grep -rIl ${bindir} ${D}${bindir}/pip3*`; do | ||
40 | sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT | ||
41 | done | ||
37 | } | 42 | } |
38 | 43 | ||
39 | RDEPENDS_${PN} = "\ | 44 | RDEPENDS_${PN} = "\ |
@@ -47,3 +52,5 @@ RDEPENDS_${PN} = "\ | |||
47 | python3-unixadmin \ | 52 | python3-unixadmin \ |
48 | python3-xmlrpc \ | 53 | python3-xmlrpc \ |
49 | " | 54 | " |
55 | |||
56 | BBCLASSEXTEND = "native" | ||