summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pip_8.1.2.bb
diff options
context:
space:
mode:
authorMing Liu <peter.x.liu@external.atlascopco.com>2016-08-09 10:01:41 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-17 10:35:42 +0100
commitbba1b911c86557db66af4baf7f15813f43c1ae70 (patch)
tree5e5ce8c78ccb5fbc6ca1aea4f08127ca14e2de3e /meta/recipes-devtools/python/python3-pip_8.1.2.bb
parent92f505b0162f666b14208e2835c7def9f2cd4f2c (diff)
downloadpoky-bba1b911c86557db66af4baf7f15813f43c1ae70.tar.gz
Use PYTHON_SITEPACKAGES_DIR insted of hard-coded *site-packages*
For thoese recipes that are inheriting python*-dir.bbclass, there is already a PYTHON_SITEPACKAGES_DIR present, use that definition replacing redundant "${libdir}/python*/site-packages". (From OE-Core rev: e7d842673952aa4aaa141f64958bc1344dbe8210) Signed-off-by: Ming Liu <peter.x.liu@external.atlascopco.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pip_8.1.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pip_8.1.2.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-devtools/python/python3-pip_8.1.2.bb b/meta/recipes-devtools/python/python3-pip_8.1.2.bb
index e319dff675..eefb4cb796 100644
--- a/meta/recipes-devtools/python/python3-pip_8.1.2.bb
+++ b/meta/recipes-devtools/python/python3-pip_8.1.2.bb
@@ -18,16 +18,16 @@ S = "${WORKDIR}/${SRCNAME}-${PV}"
18 18
19inherit distutils3 19inherit distutils3
20 20
21DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages" 21DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}"
22 22
23do_install_prepend() { 23do_install_prepend() {
24 install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages 24 install -d ${D}${PYTHON_SITEPACKAGES_DIR}
25} 25}
26 26
27# Use setuptools site.py instead, avoid shared state issue 27# Use setuptools site.py instead, avoid shared state issue
28do_install_append() { 28do_install_append() {
29 rm ${D}/${libdir}/${PYTHON_DIR}/site-packages/site.py 29 rm ${D}${PYTHON_SITEPACKAGES_DIR}/site.py
30 rm ${D}/${libdir}/${PYTHON_DIR}/site-packages/__pycache__/site.cpython-*.pyc 30 rm ${D}${PYTHON_SITEPACKAGES_DIR}/__pycache__/site.cpython-*.pyc
31 31
32 # Install as pip3 and leave pip2 as default 32 # Install as pip3 and leave pip2 as default
33 rm ${D}/${bindir}/pip 33 rm ${D}/${bindir}/pip