diff options
author | Alejandro Hernandez <alejandro.hernandez@linux.intel.com> | 2016-06-08 05:56:15 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2016-06-12 23:47:16 +0100 |
commit | 6aaeced07bf301f85a40093f5e4b8950f89740bc (patch) | |
tree | 97347ecf2da76a2c8c0e559dfa3724cf243603e8 /meta/recipes-devtools/python/python3-pip_8.1.2.bb | |
parent | 313a5f5502e06e2ebcb213f81a9494997e470b63 (diff) | |
download | poky-6aaeced07bf301f85a40093f5e4b8950f89740bc.tar.gz |
python3-pip: Upgrade from 8.0.0 to 8.1.2
(From OE-Core rev: e2e248919e31029ece26ec0f1383690ce410aa24)
Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pip_8.1.2.bb')
-rw-r--r-- | meta/recipes-devtools/python/python3-pip_8.1.2.bb | 47 |
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pip_8.1.2.bb b/meta/recipes-devtools/python/python3-pip_8.1.2.bb new file mode 100644 index 0000000000..e319dff675 --- /dev/null +++ b/meta/recipes-devtools/python/python3-pip_8.1.2.bb | |||
@@ -0,0 +1,47 @@ | |||
1 | SUMMARY = "The PyPA recommended tool for installing Python packages" | ||
2 | sHOMEPAGEsss = "https://pypi.python.org/pypi/pip" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=25fba45109565f87de20bae85bc39452" | ||
6 | |||
7 | SRCNAME = "pip" | ||
8 | DEPENDS += "python3 python3-setuptools-native" | ||
9 | |||
10 | SRC_URI = "https://files.pythonhosted.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz" | ||
11 | |||
12 | SRC_URI[md5sum] = "87083c0b9867963b29f7aba3613e8f4a" | ||
13 | SRC_URI[sha256sum] = "4d24b03ffa67638a3fa931c09fd9e0273ffa904e95ebebe7d4b1a54c93d7b732" | ||
14 | |||
15 | UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/pip" | ||
16 | |||
17 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
18 | |||
19 | inherit distutils3 | ||
20 | |||
21 | DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages" | ||
22 | |||
23 | do_install_prepend() { | ||
24 | install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages | ||
25 | } | ||
26 | |||
27 | # Use setuptools site.py instead, avoid shared state issue | ||
28 | do_install_append() { | ||
29 | rm ${D}/${libdir}/${PYTHON_DIR}/site-packages/site.py | ||
30 | rm ${D}/${libdir}/${PYTHON_DIR}/site-packages/__pycache__/site.cpython-*.pyc | ||
31 | |||
32 | # Install as pip3 and leave pip2 as default | ||
33 | rm ${D}/${bindir}/pip | ||
34 | |||
35 | # Installed eggs need to be passed directly to the interpreter via a pth file | ||
36 | echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}-${PV}.pth | ||
37 | } | ||
38 | |||
39 | RDEPENDS_${PN} = "\ | ||
40 | python3-compile \ | ||
41 | python3-io \ | ||
42 | python3-json \ | ||
43 | python3-netserver \ | ||
44 | python3-setuptools \ | ||
45 | python3-unixadmin \ | ||
46 | python3-xmlrpc \ | ||
47 | " | ||