summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pip_8.0.0.bb
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2016-01-21 17:58:00 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-25 12:44:13 +0000
commit44fee2bb7a1d2b024982c4bf4bb29d473ec30d56 (patch)
treefc7e144b8cca3794605db111b95f7e75d19c817b /meta/recipes-devtools/python/python3-pip_8.0.0.bb
parent9d95a9d15ab6bc01bdd808ff32d45ed46dc9e303 (diff)
downloadpoky-44fee2bb7a1d2b024982c4bf4bb29d473ec30d56.tar.gz
python3-pip: Upgrade to 8.0.0
LIC_FILES_CHKSUM changed, but LICESE still applies, dates changed (From OE-Core rev: e4d5df521f22ed13eca27f24899af27c7a49990a) Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pip_8.0.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pip_8.0.0.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pip_8.0.0.bb b/meta/recipes-devtools/python/python3-pip_8.0.0.bb
new file mode 100644
index 0000000000..834ecda6d7
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pip_8.0.0.bb
@@ -0,0 +1,48 @@
1SUMMARY = "The PyPA recommended tool for installing Python packages"
2sHOMEPAGEsss = "https://pypi.python.org/pypi/pip"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=25fba45109565f87de20bae85bc39452"
6
7SRCNAME = "pip"
8DEPENDS += "python3 python3-setuptools-native"
9
10SRC_URI = " \
11 http://pypi.python.org/packages/source/p/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
12"
13SRC_URI[md5sum] = "5601c4323464add1482291634142894d"
14SRC_URI[sha256sum] = "90112b296152f270cb8dddcd19b7b87488d9e002e8cf622e14c4da9c2f6319b1"
15
16UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/pip"
17
18S = "${WORKDIR}/${SRCNAME}-${PV}"
19
20inherit distutils3
21
22DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages"
23
24do_install_prepend() {
25 install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
26}
27
28# Use setuptools site.py instead, avoid shared state issue
29do_install_append() {
30 rm ${D}/${libdir}/${PYTHON_DIR}/site-packages/site.py
31 rm ${D}/${libdir}/${PYTHON_DIR}/site-packages/__pycache__/site.cpython-*.pyc
32
33 # Install as pip3 and leave pip2 as default
34 rm ${D}/${bindir}/pip
35
36 # Installed eggs need to be passed directly to the interpreter via a pth file
37 echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/${SRCNAME}-${PV}.pth
38}
39
40RDEPENDS_${PN} = "\
41 python3-compile \
42 python3-io \
43 python3-json \
44 python3-netserver \
45 python3-setuptools \
46 python3-unixadmin \
47 python3-xmlrpc \
48"