summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-pip_18.0.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-08-17 08:25:42 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-20 17:38:22 +0100
commit40fce4ea02a8a3386f402cbecffe611c36690c8c (patch)
tree80fd254433510d49d59d37b6811cc11dce57b766 /meta/recipes-devtools/python/python3-pip_18.0.bb
parent81506803a1a7eb4134ea9b09b048c4d89bab5d8b (diff)
downloadpoky-40fce4ea02a8a3386f402cbecffe611c36690c8c.tar.gz
python3-pip: update to version 18.0
License-Update: Update checksum for copyright year changes Update to the latest stable version (From OE-Core rev: 30d0e8e895813bc422d60bd00076a7f16035feeb) Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-pip_18.0.bb')
-rw-r--r--meta/recipes-devtools/python/python3-pip_18.0.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-pip_18.0.bb b/meta/recipes-devtools/python/python3-pip_18.0.bb
new file mode 100644
index 0000000000..3fcdb8014a
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-pip_18.0.bb
@@ -0,0 +1,30 @@
1SUMMARY = "The PyPA recommended tool for installing Python packages"
2HOMEPAGE = "https://pypi.python.org/pypi/pip"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=593c6cd9d639307226978cbcae61ad4b"
6
7DEPENDS += "python3 python3-setuptools-native"
8
9SRC_URI[md5sum] = "52f75ceb21e96c258f289859a2996b60"
10SRC_URI[sha256sum] = "a0e11645ee37c90b40c46d607070c4fd583e2cd46231b1c06e389c5e814eed76"
11
12inherit pypi distutils3
13
14do_install_append() {
15 # Install as pip3 and leave pip2 as default
16 rm ${D}/${bindir}/pip
17}
18
19RDEPENDS_${PN} = "\
20 python3-compile \
21 python3-io \
22 python3-html \
23 python3-json \
24 python3-netserver \
25 python3-setuptools \
26 python3-unixadmin \
27 python3-xmlrpc \
28"
29
30BBCLASSEXTEND = "native nativesdk"