summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-picobuild_0.2.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-07-15 13:32:10 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-07-18 13:24:36 +0100
commit2d1838b7bc4c2dee85d865e49425022313ac5bc1 (patch)
tree571efb98a040cebc5f40acdc1c5395daf255dd9f /meta/recipes-devtools/python/python3-picobuild_0.2.bb
parent832fb7c1c3edaf35650763af447f5aae192ef856 (diff)
downloadpoky-2d1838b7bc4c2dee85d865e49425022313ac5bc1.tar.gz
python3-picobuild: upgrade to 0.2
Major features since 0.1: - Implement support for legacy source trees - Add option to loosen dependency checking (From OE-Core rev: 5260d81dab757120114e103135dfb4c98443afa3) Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-picobuild_0.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-picobuild_0.2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-picobuild_0.2.bb b/meta/recipes-devtools/python/python3-picobuild_0.2.bb
new file mode 100644
index 0000000000..99e4cb8761
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-picobuild_0.2.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Library and tool for installing Python wheels"
2HOMEPAGE = "https://gitlab.com/rossburton/picobuild"
3LICENSE = "MIT & ( Apache-2.0 | BSD-2-Clause)"
4
5LIC_FILES_CHKSUM = "file://LICENSE;md5=6c811a9fbdf5641ff0b0d43fbbb440e5 \
6 file://picobuild/vendored/packaging/LICENSE.APACHE;md5=2ee41112a44fe7014dce33e26468ba93 \
7 file://picobuild/vendored/packaging/LICENSE.BSD;md5=7bef9bf4a8e4263634d0597e7ba100b8 \
8 file://picobuild/vendored/pep517/LICENSE;md5=aad69c93f605003e3342b174d9b0708c \
9 file://picobuild/vendored/pyparsing/LICENSE;md5=657a566233888513e1f07ba13e2f47f1 \
10 file://picobuild/vendored/tomli/LICENSE;md5=aaaaf0879d17df0110d1aa8c8c9f46f5 \
11 "
12
13SRC_URI = "git://gitlab.com/rossburton/picobuild.git;protocol=https;branch=main"
14SRCREV = "ed3b16ce48d91df181e5f5d77b9bbc2577b3fd9d"
15PV .= "+git${SRCPV}"
16
17S = "${WORKDIR}/git"
18
19inherit python_flit_core
20
21DEPENDS:remove:class-native = "python3-picobuild-native"
22
23BBCLASSEXTEND = "native nativesdk"