summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-numpy_1.21.4.bb
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2021-11-14 13:15:55 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-11-15 12:55:27 +0000
commita6757e4a5272b97b144dd474d71a290dba77925b (patch)
tree683cef25bee9c805f1bed782532d1f77084018a1 /meta/recipes-devtools/python/python3-numpy_1.21.4.bb
parent6c220ed3f411b73d2e80e15de71d022d58db2232 (diff)
downloadpoky-a6757e4a5272b97b144dd474d71a290dba77925b.tar.gz
python3-numpy: move recipe to python directory
This recipe had been moved out from python directory since 2016[1] in order to share patches between python2 and python3. But now there is no reason to keep it in its own directory as we only keep python3-nump. Move it back to python directory. [1] https://git.openembedded.org/openembedded-core/commit/?id=9bffe2f9fb4ce6c0b265f27e5b484fbe076c6349 (From OE-Core rev: e5702b8ebd16949c736b8c2f18bf35c0d64d80bd) Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-numpy_1.21.4.bb')
-rw-r--r--meta/recipes-devtools/python/python3-numpy_1.21.4.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-numpy_1.21.4.bb b/meta/recipes-devtools/python/python3-numpy_1.21.4.bb
new file mode 100644
index 0000000000..8988a5bc39
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-numpy_1.21.4.bb
@@ -0,0 +1,58 @@
1SUMMARY = "A sophisticated Numeric Processing Package for Python"
2HOMEPAGE = "https://numpy.org/"
3DESCRIPTION = "NumPy is the fundamental package needed for scientific computing with Python."
4SECTION = "devel/python"
5LICENSE = "BSD-3-Clause & BSD-2-Clause & PSF & Apache-2.0 & MIT"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b076ad374a7d311ba3126a22b2d52596"
7
8SRCNAME = "numpy"
9
10SRC_URI = "https://github.com/${SRCNAME}/${SRCNAME}/releases/download/v${PV}/${SRCNAME}-${PV}.tar.gz \
11 file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
12 file://0001-numpy-core-Define-RISCV-32-support.patch \
13 file://run-ptest \
14"
15SRC_URI[sha256sum] = "5d412381aa489b8be82ac5c6a9e99c3eb3f754245ad3f90ab5c339d92f25fb47"
16
17UPSTREAM_CHECK_URI = "https://github.com/numpy/numpy/releases"
18UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
19
20DEPENDS += "python3-cython-native"
21
22inherit ptest setuptools3
23
24S = "${WORKDIR}/numpy-${PV}"
25
26CLEANBROKEN = "1"
27
28FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a ${PYTHON_SITEPACKAGES_DIR}/numpy/random/lib/*.a"
29
30# install what is needed for numpy.test()
31RDEPENDS:${PN} = "${PYTHON_PN}-unittest \
32 ${PYTHON_PN}-difflib \
33 ${PYTHON_PN}-pprint \
34 ${PYTHON_PN}-pickle \
35 ${PYTHON_PN}-shell \
36 ${PYTHON_PN}-doctest \
37 ${PYTHON_PN}-datetime \
38 ${PYTHON_PN}-distutils \
39 ${PYTHON_PN}-misc \
40 ${PYTHON_PN}-mmap \
41 ${PYTHON_PN}-netclient \
42 ${PYTHON_PN}-numbers \
43 ${PYTHON_PN}-pydoc \
44 ${PYTHON_PN}-pkgutil \
45 ${PYTHON_PN}-email \
46 ${PYTHON_PN}-compression \
47 ${PYTHON_PN}-ctypes \
48 ${PYTHON_PN}-threading \
49 ${PYTHON_PN}-multiprocessing \
50"
51RDEPENDS:${PN}-ptest += "${PYTHON_PN}-pytest \
52 ${PYTHON_PN}-hypothesis \
53 ${PYTHON_PN}-sortedcontainers \
54 ${PYTHON_PN}-resource \
55 ldd \
56"
57
58BBCLASSEXTEND = "native nativesdk"