summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-native_3.5.6.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-09-11 12:52:38 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-09-13 07:42:28 +0100
commit53535f67aef011f0fe8365ef99ca01b8b00e4b9e (patch)
tree50bb225f08d286e4122839a14394dd4eef3e0dc4 /meta/recipes-devtools/python/python3-native_3.5.6.bb
parent3c32b1525ad5ce3ec82542846369547efc62f25a (diff)
downloadpoky-53535f67aef011f0fe8365ef99ca01b8b00e4b9e.tar.gz
python3: split common assignments into a dedicated python3.inc
Instead of including the Py2 python.inc and having to undo some of the assignments, create a new python3.inc to hold the common configuration. Over time we can move more from the recipes into this file to unify the target and native recipes. (From OE-Core rev: fc4767113adbdfbf4aeaaf6dd8605e7fd4bbaa46) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-native_3.5.6.bb')
-rw-r--r--meta/recipes-devtools/python/python3-native_3.5.6.bb17
1 files changed, 1 insertions, 16 deletions
diff --git a/meta/recipes-devtools/python/python3-native_3.5.6.bb b/meta/recipes-devtools/python/python3-native_3.5.6.bb
index 847d001fce..d5953cf4bb 100644
--- a/meta/recipes-devtools/python/python3-native_3.5.6.bb
+++ b/meta/recipes-devtools/python/python3-native_3.5.6.bb
@@ -1,7 +1,5 @@
1require recipes-devtools/python/python.inc 1require recipes-devtools/python/python3.inc
2 2
3PR = "${INC_PR}.0"
4PYTHON_MAJMIN = "3.5"
5DISTRO_SRC_URI ?= "file://sitecustomize.py" 3DISTRO_SRC_URI ?= "file://sitecustomize.py"
6DISTRO_SRC_URI_linuxstdbase = "" 4DISTRO_SRC_URI_linuxstdbase = ""
7SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \ 5SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \
@@ -31,16 +29,6 @@ file://0004-bpo-33570-TLS-1.3-ciphers-for-OpenSSL-1.1.1-GH-6976.patch \
31file://0005-bpo-30714-ALPN-changes-for-OpenSSL-1.1.0f-2305.patch \ 29file://0005-bpo-30714-ALPN-changes-for-OpenSSL-1.1.0f-2305.patch \
32" 30"
33 31
34SRC_URI[md5sum] = "f5a99f765e765336a3ebbb2a24ca2be3"
35SRC_URI[sha256sum] = "f55cde04f521f273c7cba08912921cc5642cfc15ca7b22d5829f0aff4371155f"
36
37LIC_FILES_CHKSUM = "file://LICENSE;md5=b6ec515b22618f55fa07276b897bacea"
38
39# exclude pre-releases for both python 2.x and 3.x
40UPSTREAM_CHECK_REGEX = "[Pp]ython-(?P<pver>\d+(\.\d+)+).tar"
41
42S = "${WORKDIR}/Python-${PV}"
43
44EXTRANATIVEPATH += "bzip2-native" 32EXTRANATIVEPATH += "bzip2-native"
45DEPENDS = "openssl-native bzip2-replacement-native zlib-native readline-native sqlite3-native gdbm-native" 33DEPENDS = "openssl-native bzip2-replacement-native zlib-native readline-native sqlite3-native gdbm-native"
46 34
@@ -56,9 +44,6 @@ EXTRA_OEMAKE = '\
56 ARCH=${TARGET_ARCH} \ 44 ARCH=${TARGET_ARCH} \
57' 45'
58 46
59# No ctypes option for python 3
60PYTHONLSBOPTS = ""
61
62do_configure_append() { 47do_configure_append() {
63 autoreconf --verbose --install --force --exclude=autopoint ../Python-${PV}/Modules/_ctypes/libffi 48 autoreconf --verbose --install --force --exclude=autopoint ../Python-${PV}/Modules/_ctypes/libffi
64 sed -i -e 's,#define HAVE_GETRANDOM 1,/\* #undef HAVE_GETRANDOM \*/,' ${B}/pyconfig.h 49 sed -i -e 's,#define HAVE_GETRANDOM 1,/\* #undef HAVE_GETRANDOM \*/,' ${B}/pyconfig.h