summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-native_3.5.2.bb
diff options
context:
space:
mode:
authorMing Liu <peter.x.liu@external.atlascopco.com>2017-02-26 08:44:45 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-01 23:27:10 +0000
commit2f821f3c094927572fa599e3a07931b97073642e (patch)
treecaf872e10efef9cf93c1cea7fa4ca572f643bbe4 /meta/recipes-devtools/python/python3-native_3.5.2.bb
parente720e3b4af036f0867f7616470013c714cad38e1 (diff)
downloadpoky-2f821f3c094927572fa599e3a07931b97073642e.tar.gz
generate-manifest-3.5.py: add logic to generate native manifest
python3-native supposes to RPROVIDE all native packages as added in generate-manifest-3.5.py, but it does not so far, this leads a problem that sometimes bitbake cant find a runtime provider for a python3-*-native when a new runtime dependency on it being required, this usualy happens after a new native python3-* recipe is created or the old native python3-* recipes are upgraded. To avoid manually extending RPROVIDE every time when a new runtime dependency is introduced, an argument '-n/--native' is added to the manifest generator, allowing it create a native python3 manifest, with a RPROVIDE line only, the RPROVIDE should contain all the sub-packages. The generated python-native-3.5-manifest.inc is also added which is included by python3-native recipe. (From OE-Core rev: 800753069f667cd1664d70b3779150c467e3b3fe) Signed-off-by: Ming Liu <peter.x.liu@external.atlascopco.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-native_3.5.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-native_3.5.2.bb27
1 files changed, 1 insertions, 26 deletions
diff --git a/meta/recipes-devtools/python/python3-native_3.5.2.bb b/meta/recipes-devtools/python/python3-native_3.5.2.bb
index bf4e6860fa..edcf2244f5 100644
--- a/meta/recipes-devtools/python/python3-native_3.5.2.bb
+++ b/meta/recipes-devtools/python/python3-native_3.5.2.bb
@@ -41,32 +41,7 @@ DEPENDS = "openssl-native bzip2-replacement-native zlib-native readline-native s
41 41
42inherit native 42inherit native
43 43
44RPROVIDES += " \ 44require python-native-${PYTHON_MAJMIN}-manifest.inc
45 python3-compression-native \
46 python3-core-native \
47 python3-distutils-native \
48 python3-datetime-native \
49 python3-enum-native \
50 python3-terminal-native \
51 python3-email-native \
52 python3-importlib-native \
53 python3-io-native \
54 python3-json-native \
55 python3-lang-native \
56 python3-misc-native \
57 python3-modules-native \
58 python3-netclient-native \
59 python3-netserver-native \
60 python3-numbers-native \
61 python3-pkgutil-native \
62 python3-pprint-native \
63 python3-re-native \
64 python3-shell-native \
65 python3-subprocess-native \
66 python3-textutils-native \
67 python3-threading-native \
68 python3-unittest-native \
69"
70 45
71EXTRA_OECONF_append = " --bindir=${bindir}/${PN} --without-ensurepip" 46EXTRA_OECONF_append = " --bindir=${bindir}/${PN} --without-ensurepip"
72 47