summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-native_3.5.1.bb
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2016-08-03 18:49:43 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-10 10:46:30 +0100
commit3ab991bee2d7e1588e70c08005ca8d041fe63102 (patch)
tree0a15ae884c7a314ec545181bd6937ac8e9d94b53 /meta/recipes-devtools/python/python3-native_3.5.1.bb
parentadf4266524d0d1a7814d31496c3ecc6470644ec6 (diff)
downloadpoky-3ab991bee2d7e1588e70c08005ca8d041fe63102.tar.gz
python3-native: Upgrade from 3.5.1 to 3.5.2
LICENSE did not change, only dates were changed Rebases: - 000-cross-compile.patch - python-3.3-multilib.patch (From OE-Core rev: 0a3a4047e779c8bff2b5e2bfa37b7ab119d08d4b) Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-native_3.5.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-native_3.5.1.bb76
1 files changed, 0 insertions, 76 deletions
diff --git a/meta/recipes-devtools/python/python3-native_3.5.1.bb b/meta/recipes-devtools/python/python3-native_3.5.1.bb
deleted file mode 100644
index 81ea087e88..0000000000
--- a/meta/recipes-devtools/python/python3-native_3.5.1.bb
+++ /dev/null
@@ -1,76 +0,0 @@
1require recipes-devtools/python/python.inc
2
3PR = "${INC_PR}.0"
4PYTHON_MAJMIN = "3.5"
5DISTRO_SRC_URI ?= "file://sitecustomize.py"
6DISTRO_SRC_URI_linuxstdbase = ""
7SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \
8file://12-distutils-prefix-is-inside-staging-area.patch \
9file://python-config.patch \
10file://000-cross-compile.patch \
11file://020-dont-compile-python-files.patch \
12file://030-fixup-include-dirs.patch \
13file://070-dont-clean-ipkg-install.patch \
14file://080-distutils-dont_adjust_files.patch \
15file://130-readline-setup.patch \
16file://150-fix-setupterm.patch \
17file://python-3.3-multilib.patch \
18file://03-fix-tkinter-detection.patch \
19file://avoid_warning_about_tkinter.patch \
20file://shutil-follow-symlink-fix.patch \
21file://0001-h2py-Fix-issue-13032-where-it-fails-with-UnicodeDeco.patch \
22file://sysroot-include-headers.patch \
23file://unixccompiler.patch \
24${DISTRO_SRC_URI} \
25file://sysconfig.py-add-_PYTHON_PROJECT_SRC.patch \
26file://setup.py-check-cross_compiling-when-get-FLAGS.patch \
27file://0001-Do-not-use-the-shell-version-of-python-config-that-w.patch \
28"
29SRC_URI[md5sum] = "e9ea6f2623fffcdd871b7b19113fde80"
30SRC_URI[sha256sum] = "c6d57c0c366d9060ab6c0cdf889ebf3d92711d466cc0119c441dbf2746f725c9"
31
32LIC_FILES_CHKSUM = "file://LICENSE;md5=dd98d01d471fac8d8dbdd975229dba03"
33
34# exclude pre-releases for both python 2.x and 3.x
35UPSTREAM_CHECK_REGEX = "[Pp]ython-(?P<pver>\d+(\.\d+)+).tar"
36
37S = "${WORKDIR}/Python-${PV}"
38
39EXTRANATIVEPATH += "bzip2-native"
40DEPENDS = "openssl-native bzip2-replacement-native zlib-native readline-native sqlite3-native"
41
42inherit native
43
44RPROVIDES += "python3-distutils-native python3-compression-native python3-textutils-native python3-core-native python3-importlib-native python3-io-native"
45
46EXTRA_OECONF_append = " --bindir=${bindir}/${PN} --without-ensurepip"
47
48EXTRA_OEMAKE = '\
49 LIBC="" \
50 STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \
51 STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
52 LIB=${baselib} \
53 ARCH=${TARGET_ARCH} \
54'
55
56# No ctypes option for python 3
57PYTHONLSBOPTS = ""
58
59do_configure_append() {
60 autoreconf --verbose --install --force --exclude=autopoint ../Python-${PV}/Modules/_ctypes/libffi
61}
62
63do_install() {
64 install -d ${D}${libdir}/pkgconfig
65 oe_runmake 'DESTDIR=${D}' install
66 if [ -e ${WORKDIR}/sitecustomize.py ]; then
67 install -m 0644 ${WORKDIR}/sitecustomize.py ${D}/${libdir}/python${PYTHON_MAJMIN}
68 fi
69 install -d ${D}${bindir}/${PN}
70 install -m 0755 Parser/pgen ${D}${bindir}/${PN}
71
72 # Make sure we use /usr/bin/env python
73 for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
74 sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
75 done
76}