summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-native_3.4.3.bb
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2015-05-12 15:09:50 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-15 17:44:59 +0100
commit79a2fc2f6c84265baefcdb6bb74c4da3b8b600d4 (patch)
treeeb57ba6cbcac9168cd726154346db009dbdde6f0 /meta/recipes-devtools/python/python3-native_3.4.3.bb
parent1237db6ee335f5b4cbdad98da3fff5284afb603b (diff)
downloadpoky-79a2fc2f6c84265baefcdb6bb74c4da3b8b600d4.tar.gz
python3: Upgrade from 3.4.2 to 3.4.3
Modifies: python3-native_3.4.2.bb -> python3-native_3.4.3.bb: Updates checksums, LICENSE did not change, dates were updated. python3_3.4.2.bb -> python3_3.4.3.bb: Updates checksums, LICENSE did not change, dates were updated. generate-manifest-3.4.py: fixes asyncio and net-tools. python-3.4-manifest.inc: fixes asyncio and net-tools. This upgrade contains a fix for CVE-2014-9365. (From OE-Core rev: 94fc3b199c169b1da850c0aade530ddcf1544d81) Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-native_3.4.3.bb')
-rw-r--r--meta/recipes-devtools/python/python3-native_3.4.3.bb76
1 files changed, 76 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-native_3.4.3.bb b/meta/recipes-devtools/python/python3-native_3.4.3.bb
new file mode 100644
index 0000000000..464ff05802
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-native_3.4.3.bb
@@ -0,0 +1,76 @@
1require recipes-devtools/python/python.inc
2
3PR = "${INC_PR}.0"
4PYTHON_MAJMIN = "3.4"
5DISTRO_SRC_URI ?= "file://sitecustomize.py"
6DISTRO_SRC_URI_linuxstdbase = ""
7SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.xz \
8file://12-distutils-prefix-is-inside-staging-area.patch \
9file://python-config.patch \
10file://000-cross-compile.patch \
11file://020-dont-compile-python-files.patch \
12file://030-fixup-include-dirs.patch \
13file://070-dont-clean-ipkg-install.patch \
14file://080-distutils-dont_adjust_files.patch \
15file://110-enable-zlib.patch \
16file://130-readline-setup.patch \
17file://150-fix-setupterm.patch \
18file://python-3.3-multilib.patch \
19file://03-fix-tkinter-detection.patch \
20file://avoid_warning_about_tkinter.patch \
21file://shutil-follow-symlink-fix.patch \
22file://0001-h2py-Fix-issue-13032-where-it-fails-with-UnicodeDeco.patch \
23file://sysroot-include-headers.patch \
24file://unixccompiler.patch \
25file://makerace.patch \
26${DISTRO_SRC_URI} \
27file://sysconfig.py-add-_PYTHON_PROJECT_SRC.patch \
28file://setup.py-check-cross_compiling-when-get-FLAGS.patch \
29"
30SRC_URI[md5sum] = "7d092d1bba6e17f0d9bd21b49e441dd5"
31SRC_URI[sha256sum] = "b5b3963533768d5fc325a4d7a6bd6f666726002d696f1d399ec06b043ea996b8"
32
33LIC_FILES_CHKSUM = "file://LICENSE;md5=dd98d01d471fac8d8dbdd975229dba03"
34
35S = "${WORKDIR}/Python-${PV}"
36
37EXTRANATIVEPATH += "bzip2-native"
38DEPENDS = "openssl-native bzip2-replacement-native zlib-native readline-native sqlite3-native"
39
40inherit native
41
42RPROVIDES += "python3-distutils-native python3-compression-native python3-textutils-native python3-core-native"
43
44EXTRA_OECONF_append = " --bindir=${bindir}/${PN} --without-ensurepip"
45
46EXTRA_OEMAKE = '\
47 BUILD_SYS="" \
48 HOST_SYS="" \
49 LIBC="" \
50 STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \
51 STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
52 LIB=${baselib} \
53 ARCH=${TARGET_ARCH} \
54'
55
56# No ctypes option for python 3
57PYTHONLSBOPTS = ""
58
59do_configure_append() {
60 autoreconf --verbose --install --force --exclude=autopoint ../Python-${PV}/Modules/_ctypes/libffi
61}
62
63do_install() {
64 install -d ${D}${libdir}/pkgconfig
65 oe_runmake 'DESTDIR=${D}' install
66 if [ -e ${WORKDIR}/sitecustomize.py ]; then
67 install -m 0644 ${WORKDIR}/sitecustomize.py ${D}/${libdir}/python${PYTHON_MAJMIN}
68 fi
69 install -d ${D}${bindir}/${PN}
70 install -m 0755 Parser/pgen ${D}${bindir}/${PN}
71
72 # Make sure we use /usr/bin/env python
73 for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do
74 sed -i -e '1s|^#!.*|#!/usr/bin/env python3|' $PYTHSCRIPT
75 done
76}