summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-magic_0.4.27.bb
diff options
context:
space:
mode:
authorXu Huan <xuhuan.fnst@fujitsu.com>2022-06-17 09:37:50 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-06-21 18:44:27 +0100
commit4fb44ddc00a921875f426a7810984509a6612df3 (patch)
tree1179eb1e6826c313929f8adeafa2af113190fb98 /meta/recipes-devtools/python/python3-magic_0.4.27.bb
parent672a8caece7073c86cbac31e8ee2dadc9d3f3820 (diff)
downloadpoky-4fb44ddc00a921875f426a7810984509a6612df3.tar.gz
python3-magic: upgrade 0.4.26 -> 0.4.27
Changes to 0.4.27: - remove spurious pyproject.toml that breaks source builds (From OE-Core rev: 0027181986d2c6bafb7d0673903efb85dcd3ad88) Signed-off-by: Xu Huan <xuhuan.fnst@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-magic_0.4.27.bb')
-rw-r--r--meta/recipes-devtools/python/python3-magic_0.4.27.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-magic_0.4.27.bb b/meta/recipes-devtools/python/python3-magic_0.4.27.bb
new file mode 100644
index 0000000000..be58cdb71a
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-magic_0.4.27.bb
@@ -0,0 +1,22 @@
1SUMMARY = "File type identification using libmagic"
2DESCRIPTION = "This module uses ctypes to access the libmagic file type \
3 identification library. It makes use of the local magic database and supports \
4 both textual and MIME-type output."
5HOMEPAGE = "http://github.com/ahupp/python-magic"
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=61495c152d794e6be5799a9edca149e3"
9
10PYPI_PACKAGE = "python-magic"
11
12inherit pypi setuptools3
13
14SRC_URI[sha256sum] = "c1ba14b08e4a5f5c31a302b7721239695b2f0f058d125bd5ce1ee36b9d9d3c3b"
15
16RDEPENDS:${PN} += "file \
17 ${PYTHON_PN}-ctypes \
18 ${PYTHON_PN}-io \
19 ${PYTHON_PN}-logging \
20 ${PYTHON_PN}-shell"
21
22BBCLASSEXTEND = "native"