summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-magic_0.4.24.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-06-15 10:12:35 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-06-17 00:07:06 +0100
commit5ef04a0096644b81be5c0dd25dcc8aa81ff3e60d (patch)
treeb66623118b0c932a745beb45a493061484dea88e /meta/recipes-devtools/python/python3-magic_0.4.24.bb
parent7c57d7405cca617b3e051de9f7138eac55db4894 (diff)
downloadpoky-5ef04a0096644b81be5c0dd25dcc8aa81ff3e60d.tar.gz
python3-magic: upgrade 0.4.23 -> 0.4.24
(From OE-Core rev: d74386b7b7fd2a7e6b3179c123b15331341fafa8) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-magic_0.4.24.bb')
-rw-r--r--meta/recipes-devtools/python/python3-magic_0.4.24.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-magic_0.4.24.bb b/meta/recipes-devtools/python/python3-magic_0.4.24.bb
new file mode 100644
index 0000000000..a54bf2431c
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-magic_0.4.24.bb
@@ -0,0 +1,22 @@
1SUMMARY = "File type identification using libmagic"
2DESCRIPTION = "This module uses ctypes to access the libmagic file type \
3 identification library. It makes use of the local magic database and supports \
4 both textual and MIME-type output."
5HOMEPAGE = "http://github.com/ahupp/python-magic"
6
7LICENSE = "MIT"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=61495c152d794e6be5799a9edca149e3"
9
10PYPI_PACKAGE = "python-magic"
11
12inherit pypi setuptools3
13
14SRC_URI[sha256sum] = "de800df9fb50f8ec5974761054a708af6e4246b03b4bdaee993f948947b0ebcf"
15
16RDEPENDS_${PN} += "file \
17 ${PYTHON_PN}-ctypes \
18 ${PYTHON_PN}-io \
19 ${PYTHON_PN}-logging \
20 ${PYTHON_PN}-shell"
21
22BBCLASSEXTEND = "native"