summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-jsonschema_4.7.2.bb
diff options
context:
space:
mode:
authorJan Vermaete <jan.vermaete@gmail.com>2022-07-17 10:29:53 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-07-19 10:54:20 +0100
commit957e82e19b2522e7bb43cd736c7343e4df465ee3 (patch)
treefd2eb88730f47e49ef3e1b99b92bbf7634de42e0 /meta/recipes-devtools/python/python3-jsonschema_4.7.2.bb
parent476a89a436a57d63804a76f8de2c7a9275a34c44 (diff)
downloadpoky-957e82e19b2522e7bb43cd736c7343e4df465ee3.tar.gz
python3-jsonschema: 4.7.1 -> 4.7.2 + fixed the rdepends
And spitted the files for the tests into a -test package buildhistory: images/raspberrypi4_64/glibc/core-image-base: IMAGESIZE changed from 208024 to 183660 (-12%) Changes to images/raspberrypi4_64/glibc/core-image-base (installed-package-names.txt): python3-pyparsing was removed python3-pip was removed python3-setuptools-scm was removed python3-packaging was removed python3-typing-extensions was removed python3-pkg-resources was removed python3-tomli was removed python3-setuptools was removed (From OE-Core rev: d744882251236800412870922b30ddbc70d214e5) Signed-off-by: Jan Vermaete <jan.vermaete@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-jsonschema_4.7.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-jsonschema_4.7.2.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-jsonschema_4.7.2.bb b/meta/recipes-devtools/python/python3-jsonschema_4.7.2.bb
new file mode 100644
index 0000000000..af728ab2d6
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-jsonschema_4.7.2.bb
@@ -0,0 +1,48 @@
1SUMMARY = "An implementation of JSON Schema validation for Python"
2HOMEPAGE = "https://github.com/Julian/jsonschema"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://COPYING;md5=7a60a81c146ec25599a3e1dabb8610a8 \
5 file://json/LICENSE;md5=9d4de43111d33570c8fe49b4cb0e01af"
6
7SRC_URI[sha256sum] = "73764f461d61eb97a057c929368610a134d1d1fffd858acfe88864ee94f1f1d3"
8
9inherit pypi python_hatchling
10
11PACKAGES =+ "${PN}-tests"
12FILES:${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/jsonschema/tests"
13
14DEPENDS += "${PYTHON_PN}-hatch-vcs-native"
15
16PACKAGECONFIG ??= "format"
17PACKAGECONFIG[format] = ",,,\
18 ${PYTHON_PN}-idna \
19 ${PYTHON_PN}-jsonpointer \
20 ${PYTHON_PN}-webcolors \
21 ${PYTHON_PN}-rfc3987 \
22 ${PYTHON_PN}-strict-rfc3339 \
23"
24PACKAGECONFIG[nongpl] = ",,,\
25 ${PYTHON_PN}-idna \
26 ${PYTHON_PN}-jsonpointer \
27 ${PYTHON_PN}-webcolors \
28 ${PYTHON_PN}-rfc3986-validator \
29 ${PYTHON_PN}-rfc3339-validator \
30"
31
32RDEPENDS:${PN} += " \
33 ${PYTHON_PN}-attrs \
34 ${PYTHON_PN}-core \
35 ${PYTHON_PN}-datetime \
36 ${PYTHON_PN}-importlib-metadata \
37 ${PYTHON_PN}-io \
38 ${PYTHON_PN}-json \
39 ${PYTHON_PN}-netclient \
40 ${PYTHON_PN}-numbers \
41 ${PYTHON_PN}-pprint \
42 ${PYTHON_PN}-pyrsistent \
43 ${PYTHON_PN}-zipp \
44"
45
46RDEPENDS:${PN}-tests = "${PN}"
47
48BBCLASSEXTEND = "native nativesdk"