summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-jinja2_2.11.2.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-09-21 12:55:28 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-09-23 14:39:45 +0100
commit7ff8c823bf6b7781891e31c1d130dc4ab0fed03d (patch)
tree29a03f1026607df7ae648952bc6e346336807661 /meta/recipes-devtools/python/python3-jinja2_2.11.2.bb
parente9c6f6a142047ce31e1d8de6a24b0ec7bf75e2e3 (diff)
downloadpoky-7ff8c823bf6b7781891e31c1d130dc4ab0fed03d.tar.gz
python3-jinja2: Import from meta-oe/meta-python
This is used by some of the results handling code and needed as part of buildtools tarball on various autobuilder worker for testing. ptest is disabled for OE-Core, at least for now since it depends on python3-pytest which in turn has may other dependencies. Acked-by: Tim Orling <ticotimo@gmail.com> (From OE-Core rev: b5156e95e9e80e3e0f7eea181cd12f85e03a111d) Signed-off-by: Tim Orling <ticotimo@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-jinja2_2.11.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-jinja2_2.11.2.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-jinja2_2.11.2.bb b/meta/recipes-devtools/python/python3-jinja2_2.11.2.bb
new file mode 100644
index 0000000000..89538d2f27
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-jinja2_2.11.2.bb
@@ -0,0 +1,45 @@
1DESCRIPTION = "Python Jinja2: A small but fast and easy to use stand-alone template engine written in pure python."
2
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=5dc88300786f1c214c1e9827a5229462"
5
6SRC_URI[sha256sum] = "89aab215427ef59c34ad58735269eb58b1a5808103067f7bb9d5836c651b3bb0"
7
8PYPI_PACKAGE = "Jinja2"
9
10CLEANBROKEN = "1"
11
12inherit pypi setuptools3
13# ptest disabled in OE-Core for now due to missing dependencies
14
15
16SRC_URI += " \
17 file://run-ptest \
18"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23}
24
25RDEPENDS_${PN}-ptest += " \
26 ${PYTHON_PN}-pytest \
27 ${PYTHON_PN}-unixadmin \
28"
29
30RDEPENDS_${PN} += " \
31 ${PYTHON_PN}-asyncio \
32 ${PYTHON_PN}-crypt \
33 ${PYTHON_PN}-io \
34 ${PYTHON_PN}-json \
35 ${PYTHON_PN}-markupsafe \
36 ${PYTHON_PN}-math \
37 ${PYTHON_PN}-netclient \
38 ${PYTHON_PN}-numbers\
39 ${PYTHON_PN}-pickle \
40 ${PYTHON_PN}-pprint \
41 ${PYTHON_PN}-shell \
42 ${PYTHON_PN}-threading \
43"
44
45BBCLASSEXTEND = "native nativesdk"