summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-jinja2_2.11.2.bb
diff options
context:
space:
mode:
authorLee Chee Yang <chee.yang.lee@intel.com>2021-05-11 18:59:07 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-05-20 12:36:41 +0100
commit515203d45c1e7806e191dd7ea16f12ac2e8c7ae5 (patch)
tree3329845f6883afd928386ea1ad990a605ff1e36b /meta/recipes-devtools/python/python3-jinja2_2.11.2.bb
parent5471428610888c7ce997730f3d260476496340ca (diff)
downloadpoky-515203d45c1e7806e191dd7ea16f12ac2e8c7ae5.tar.gz
python3-jinja2: 2.11.2 -> 2.11.3
updates include fix for CVE-2020-28493 changelog: https://jinja.palletsprojects.com/en/2.11.x/changelog/#version-2-11-3 (From OE-Core rev: 9485d568b2b9e2143e1f46859a5c1de644c69b94) Signed-off-by: Lee Chee Yang <chee.yang.lee@intel.com> Signed-off-by: Steve Sakoman <steve@sakoman.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-jinja2_2.11.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-jinja2_2.11.2.bb48
1 files changed, 0 insertions, 48 deletions
diff --git a/meta/recipes-devtools/python/python3-jinja2_2.11.2.bb b/meta/recipes-devtools/python/python3-jinja2_2.11.2.bb
deleted file mode 100644
index 45167d52a2..0000000000
--- a/meta/recipes-devtools/python/python3-jinja2_2.11.2.bb
+++ /dev/null
@@ -1,48 +0,0 @@
1DESCRIPTION = "Python Jinja2: A small but fast and easy to use stand-alone template engine written in pure python."
2HOMEPAGE = "https://pypi.org/project/Jinja/"
3
4LICENSE = "BSD-3-Clause"
5LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=5dc88300786f1c214c1e9827a5229462"
6
7SRC_URI[sha256sum] = "89aab215427ef59c34ad58735269eb58b1a5808103067f7bb9d5836c651b3bb0"
8
9PYPI_PACKAGE = "Jinja2"
10
11CVE_PRODUCT = "jinja2 jinja"
12
13CLEANBROKEN = "1"
14
15inherit pypi setuptools3
16# ptest disabled in OE-Core for now due to missing dependencies
17
18
19SRC_URI += " \
20 file://run-ptest \
21"
22
23do_install_ptest() {
24 install -d ${D}${PTEST_PATH}/tests
25 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
26}
27
28RDEPENDS_${PN}-ptest += " \
29 ${PYTHON_PN}-pytest \
30 ${PYTHON_PN}-unixadmin \
31"
32
33RDEPENDS_${PN} += " \
34 ${PYTHON_PN}-asyncio \
35 ${PYTHON_PN}-crypt \
36 ${PYTHON_PN}-io \
37 ${PYTHON_PN}-json \
38 ${PYTHON_PN}-markupsafe \
39 ${PYTHON_PN}-math \
40 ${PYTHON_PN}-netclient \
41 ${PYTHON_PN}-numbers\
42 ${PYTHON_PN}-pickle \
43 ${PYTHON_PN}-pprint \
44 ${PYTHON_PN}-shell \
45 ${PYTHON_PN}-threading \
46"
47
48BBCLASSEXTEND = "native nativesdk"