summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-iniparse_0.4.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-03-27 16:19:55 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-28 08:43:13 +0100
commit8c1c392ca34da1c64336d0aa2d0a26b9c23d8d39 (patch)
tree37f509b2269d4a37cebcde905b84ec2e52c61d18 /meta/recipes-devtools/python/python3-iniparse_0.4.bb
parent3d29214b20433a506a3d59cdc08fc1a9be09a5a0 (diff)
downloadpoky-8c1c392ca34da1c64336d0aa2d0a26b9c23d8d39.tar.gz
dnf: move the entire dnf/rpm4 stack to Python 3
[YOCTO #11180] (From OE-Core rev: bedcdc4cf921b70a8cfb16c6684668d0ac9e1942) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-iniparse_0.4.bb')
-rw-r--r--meta/recipes-devtools/python/python3-iniparse_0.4.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-iniparse_0.4.bb b/meta/recipes-devtools/python/python3-iniparse_0.4.bb
new file mode 100644
index 0000000000..44e3c37f85
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-iniparse_0.4.bb
@@ -0,0 +1,19 @@
1SUMMARY = "Accessing and Modifying INI files"
2HOMEPAGE = "https://pypi.python.org/pypi/iniparse/"
3LICENSE = "MIT & PSF"
4LIC_FILES_CHKSUM = "file://LICENSE-PSF;md5=1c78a5bb3584b353496d5f6f34edb4b2 \
5 file://LICENSE;md5=52f28065af11d69382693b45b5a8eb54"
6
7SRC_URI = "https://files.pythonhosted.org/packages/source/i/iniparse/iniparse-${PV}.tar.gz \
8 file://0001-Add-python-3-compatibility.patch "
9SRC_URI[md5sum] = "5e573e9e9733d97623881ce9bbe5eca6"
10SRC_URI[sha256sum] = "abc1ee12d2cfb2506109072d6c21e40b6c75a3fe90a9c924327d80bc0d99c054"
11
12inherit distutils3
13
14RDEPENDS_${PN} += "python3-core python3-six"
15DEPENDS += "python3-six"
16
17BBCLASSEXTEND = "native nativesdk"
18
19S = "${WORKDIR}/iniparse-${PV}"