summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-hypothesis_6.46.11.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2022-06-06 20:27:13 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-06-07 21:21:55 +0100
commit53789b1a77468510b743a84786f7afb13b4bbf15 (patch)
tree1094b967d1dd394c828e5a2ac05d44836fdd9ac0 /meta/recipes-devtools/python/python3-hypothesis_6.46.11.bb
parent5356536190580ece01ff1a9e44227006848dbdaa (diff)
downloadpoky-53789b1a77468510b743a84786f7afb13b4bbf15.tar.gz
python3-hypothesis: upgrade 6.46.9 -> 6.46.11
Changelog: =========== Mention "hypothesis.strategies.timezones()" in the documentation of "hypothesis.strategies.datetimes()" for completeness. (From OE-Core rev: f94e8b189a6a8819f54ced4d380bd35b261ec2d9) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-hypothesis_6.46.11.bb')
-rw-r--r--meta/recipes-devtools/python/python3-hypothesis_6.46.11.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-hypothesis_6.46.11.bb b/meta/recipes-devtools/python/python3-hypothesis_6.46.11.bb
new file mode 100644
index 0000000000..1d9772d4ff
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-hypothesis_6.46.11.bb
@@ -0,0 +1,38 @@
1SUMMARY = "A library for property-based testing"
2HOMEPAGE = "https://github.com/HypothesisWorks/hypothesis/tree/master/hypothesis-python"
3LICENSE = "MPL-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4ee62c16ebd0f4f99d906f36b7de8c3c"
5
6PYPI_PACKAGE = "hypothesis"
7
8inherit pypi setuptools3 ptest
9
10SRC_URI += " \
11 file://run-ptest \
12 file://test_binary_search.py \
13 file://test_rle.py \
14 "
15
16SRC_URI[sha256sum] = "f5c1cf61b24b094355577a6b8fbbb8eb54c1b0216fbc0519af97c46bddf43c42"
17
18RDEPENDS:${PN} += " \
19 python3-attrs \
20 python3-compression \
21 python3-core \
22 python3-json \
23 python3-sortedcontainers \
24 python3-statistics \
25 python3-unittest \
26 "
27
28RDEPENDS:${PN}-ptest += " \
29 ${PYTHON_PN}-pytest \
30 "
31
32do_install_ptest() {
33 install -d ${D}${PTEST_PATH}/examples
34 install -m 0755 ${WORKDIR}/test_binary_search.py ${D}${PTEST_PATH}/examples/
35 install -m 0755 ${WORKDIR}/test_rle.py ${D}${PTEST_PATH}/examples/
36}
37
38BBCLASSEXTEND = "native nativesdk"