summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-git_3.1.31.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-03-05 16:06:42 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-03-06 09:52:16 +0000
commitbac739e2176ffd18dc153bbb95448d4768b051b9 (patch)
tree75d37e19f8e7ea78cf3bf0b739da6d375dbbb5a1 /meta/recipes-devtools/python/python3-git_3.1.31.bb
parent973f58762aed8390ecf4133bf219aef3c6aaaacc (diff)
downloadpoky-bac739e2176ffd18dc153bbb95448d4768b051b9.tar.gz
python3-git: upgrade 3.1.30 -> 3.1.31
(From OE-Core rev: 85f0b71edc205dab732325eae46a1c1232b29e82) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-git_3.1.31.bb')
-rw-r--r--meta/recipes-devtools/python/python3-git_3.1.31.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-git_3.1.31.bb b/meta/recipes-devtools/python/python3-git_3.1.31.bb
new file mode 100644
index 0000000000..08b9f66bcb
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-git_3.1.31.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Python library used to interact with Git repositories"
2DESCRIPTION = "GitPython provides object model read and write access to \
3a git repository. Access repository information conveniently, alter the \
4index directly, handle remotes, or go down to low-level object database \
5access with big-files support."
6HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
7SECTION = "devel/python"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=8b8d26c37c1d5a04f9b0186edbebc183"
10
11PYPI_PACKAGE = "GitPython"
12
13inherit pypi python_setuptools_build_meta
14
15SRC_URI[sha256sum] = "8ce3bcf69adfdf7c7d503e78fd3b1c492af782d58893b650adb2ac8912ddd573"
16
17DEPENDS += " ${PYTHON_PN}-gitdb"
18
19RDEPENDS:${PN} += " \
20 ${PYTHON_PN}-datetime \
21 ${PYTHON_PN}-gitdb \
22 ${PYTHON_PN}-io \
23 ${PYTHON_PN}-logging \
24 ${PYTHON_PN}-math \
25 ${PYTHON_PN}-netclient \
26 ${PYTHON_PN}-stringold \
27 ${PYTHON_PN}-unittest \
28 ${PYTHON_PN}-unixadmin \
29 git \
30"
31
32BBCLASSEXTEND = "native nativesdk"