summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-git_3.0.5.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-01-29 10:07:32 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-03 13:03:32 +0000
commita3b271954fc8a4a9581b9340765c6edd67f31e08 (patch)
tree1a548d8c9db0b4fb4181755868d00f0cbc97d2fa /meta/recipes-devtools/python/python3-git_3.0.5.bb
parent79cc1e2c25d1c5ff3e88e6b8b5674f453f928241 (diff)
downloadpoky-a3b271954fc8a4a9581b9340765c6edd67f31e08.tar.gz
python3-git: upgrade 3.0.2 -> 3.0.5
(From OE-Core rev: d19ba66daad9aef683a7dee0c59af29234201574) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-git_3.0.5.bb')
-rw-r--r--meta/recipes-devtools/python/python3-git_3.0.5.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-git_3.0.5.bb b/meta/recipes-devtools/python/python3-git_3.0.5.bb
new file mode 100644
index 0000000000..36313ef8b9
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-git_3.0.5.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Python library used to interact with Git repositories"
2DESCRIPTION = "GitPython provides object model read and write access to \
3a git repository. Access repository information conveniently, alter the \
4index directly, handle remotes, or go down to low-level object database \
5access with big-files support."
6HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
7SECTION = "devel/python"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=8b8d26c37c1d5a04f9b0186edbebc183"
10
11PYPI_PACKAGE = "GitPython"
12
13inherit pypi setuptools3
14
15SRC_URI[md5sum] = "7555ad89a22f663c25cced5f623bdef0"
16SRC_URI[sha256sum] = "9c2398ffc3dcb3c40b27324b316f08a4f93ad646d5a6328cafbb871aa79f5e42"
17
18DEPENDS += " ${PYTHON_PN}-gitdb"
19
20RDEPENDS_${PN} += " \
21 ${PYTHON_PN}-datetime \
22 ${PYTHON_PN}-gitdb \
23 ${PYTHON_PN}-io \
24 ${PYTHON_PN}-logging \
25 ${PYTHON_PN}-math \
26 ${PYTHON_PN}-netclient \
27 ${PYTHON_PN}-stringold \
28 ${PYTHON_PN}-unittest \
29 ${PYTHON_PN}-unixadmin \
30 git \
31"
32
33BBCLASSEXTEND = "native nativesdk"