summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-git_3.0.2.bb
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2019-09-05 17:51:53 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-06 14:58:10 +0100
commitb03278ba4cf32cf40d8986fa68489cf34a6d29ce (patch)
tree75fc4a7516e1982246dc0e7393f402bc8dd69514 /meta/recipes-devtools/python/python3-git_3.0.2.bb
parentcc90f61d23712ed8bc6aab4ffdf1d2def9eb3b76 (diff)
downloadpoky-b03278ba4cf32cf40d8986fa68489cf34a6d29ce.tar.gz
python3-git: update to 3.0.2
(From OE-Core rev: 1ce8a78e59e472d80a85667916af23c7d64bb99f) Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-git_3.0.2.bb')
-rw-r--r--meta/recipes-devtools/python/python3-git_3.0.2.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-git_3.0.2.bb b/meta/recipes-devtools/python/python3-git_3.0.2.bb
new file mode 100644
index 0000000000..9dd753db4f
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-git_3.0.2.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Python library used to interact with Git repositories"
2DESCRIPTION = "GitPython provides object model read and write access to \
3a git repository. Access repository information conveniently, alter the \
4index directly, handle remotes, or go down to low-level object database \
5access with big-files support."
6HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
7SECTION = "devel/python"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=8b8d26c37c1d5a04f9b0186edbebc183"
10
11PYPI_PACKAGE = "GitPython"
12
13inherit pypi setuptools3
14
15SRC_URI[md5sum] = "ccec14a5c9f18702406122983d80032c"
16SRC_URI[sha256sum] = "d2f4945f8260f6981d724f5957bc076398ada55cb5d25aaee10108bcdc894100"
17
18DEPENDS += " ${PYTHON_PN}-gitdb"
19
20RDEPENDS_${PN} += " \
21 ${PYTHON_PN}-datetime \
22 ${PYTHON_PN}-gitdb \
23 ${PYTHON_PN}-io \
24 ${PYTHON_PN}-logging \
25 ${PYTHON_PN}-math \
26 ${PYTHON_PN}-netclient \
27 ${PYTHON_PN}-stringold \
28 ${PYTHON_PN}-unittest \
29 ${PYTHON_PN}-unixadmin \
30 git \
31"
32
33BBCLASSEXTEND = "native nativesdk"