summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-dbus_1.2.8.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-06-30 05:11:01 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-05 11:39:06 +0100
commitec9ad3648bd9882fd2004bf5fcb0e0f55e160cc8 (patch)
tree976cd94dcd17cf8a69ccd054cf4ed26d643ce275 /meta/recipes-devtools/python/python3-dbus_1.2.8.bb
parent280239af327c07bb0498b2e712991d0a6be12856 (diff)
downloadpoky-ec9ad3648bd9882fd2004bf5fcb0e0f55e160cc8.tar.gz
python3-dbus: update to latest stable version of 1.2.8
Remove the PACKAGECONFIG for documentation as it now requires python3-sphinx which is not provided in any existing recipe. (From OE-Core rev: 32dded1bd2f6c5cf6437330830399b72f15096c4) Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-dbus_1.2.8.bb')
-rw-r--r--meta/recipes-devtools/python/python3-dbus_1.2.8.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-dbus_1.2.8.bb b/meta/recipes-devtools/python/python3-dbus_1.2.8.bb
new file mode 100644
index 0000000000..c9bf8df42d
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-dbus_1.2.8.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Python bindings for the DBus inter-process communication system"
2SECTION = "devel/python"
3HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b03240518994df6d8c974675675e5ca4"
6DEPENDS = "expat dbus dbus-glib virtual/libintl"
7
8SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \
9"
10
11SRC_URI[md5sum] = "7379db774c10904f27e7e2743d90fb43"
12SRC_URI[sha256sum] = "abf12bbb765e300bf8e2a1b2f32f85949eab06998dbda127952c31cb63957b6f"
13S = "${WORKDIR}/dbus-python-${PV}"
14
15inherit distutils3-base autotools pkgconfig
16
17# documentation needs python3-sphinx, which is not in oe-core or meta-python for now
18# change to use PACKAGECONFIG when python3-sphinx is added to oe-core
19EXTRA_OECONF += "--disable-documentation"
20
21
22RDEPENDS_${PN} = "python3-io python3-logging python3-stringold python3-threading python3-xml"
23
24FILES_${PN}-dev += "${libdir}/pkgconfig"