summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-dbus_1.2.4.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-06-02 12:25:39 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-03 13:13:25 +0100
commit141fa73f97d72e074f7c1a3ce1efe1cd84f07b78 (patch)
tree290ac427183b7c9f45a7ace971b080c2188fd960 /meta/recipes-devtools/python/python3-dbus_1.2.4.bb
parenta17e1599a3c9ac61fafbfa88c5d06d0f4c483417 (diff)
downloadpoky-141fa73f97d72e074f7c1a3ce1efe1cd84f07b78.tar.gz
python-dbus: update to 1.2.4, port to python 3
(From OE-Core rev: 691032c4f0e424c3a097a015a14279ea0a6dd71d) Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-dbus_1.2.4.bb')
-rw-r--r--meta/recipes-devtools/python/python3-dbus_1.2.4.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-dbus_1.2.4.bb b/meta/recipes-devtools/python/python3-dbus_1.2.4.bb
new file mode 100644
index 0000000000..c058cafcf1
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-dbus_1.2.4.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Python bindings for the DBus inter-process communication system"
2SECTION = "devel/python"
3HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=0b83047ce9e948b67c0facc5f233476a"
6DEPENDS = "expat dbus dbus-glib virtual/libintl"
7
8SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz \
9"
10
11SRC_URI[md5sum] = "7372a588c83a7232b4e08159bfd48fe5"
12SRC_URI[sha256sum] = "e2f1d6871f74fba23652e51d10873e54f71adab0525833c19bad9e99b1b2f9cc"
13S = "${WORKDIR}/dbus-python-${PV}"
14
15inherit distutils3-base autotools pkgconfig
16
17PACKAGECONFIG ?= ""
18PACKAGECONFIG[docs] = "--enable-html-docs,--disable-html-docs,python-docutils-native"
19PACKAGECONFIG[api-docs] = "--enable-api-docs,--disable-api-docs,python-docutils-native python-epydoc-native"
20
21do_configure_prepend() {
22 export PYTHON=${PYTHON}
23}
24
25RDEPENDS_${PN} = "python3-io python3-logging python3-stringold python3-threading python3-xml"
26
27FILES_${PN}-dev += "${libdir}/pkgconfig"