summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-dbus_1.2.12.bb
diff options
context:
space:
mode:
authorOleksandr Kravchuk <open.source@oleksandr-kravchuk.com>2019-09-13 21:37:24 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-09-18 12:09:02 +0100
commit2625e2d9144ae56ea5b4effc2891d5016978f5e0 (patch)
tree8c8e426de17b870d2138783401a0261014829ee0 /meta/recipes-devtools/python/python3-dbus_1.2.12.bb
parent0e599227ee416006de3b32ce65b24704f4ad1beb (diff)
downloadpoky-2625e2d9144ae56ea5b4effc2891d5016978f5e0.tar.gz
python3-dbus: update to 1.2.12
(From OE-Core rev: f53dda53067ba7d17317e54cdec7b07f693158bd) Signed-off-by: Oleksandr Kravchuk <open.source@oleksandr-kravchuk.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-dbus_1.2.12.bb')
-rw-r--r--meta/recipes-devtools/python/python3-dbus_1.2.12.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-dbus_1.2.12.bb b/meta/recipes-devtools/python/python3-dbus_1.2.12.bb
new file mode 100644
index 0000000000..d005dc4a90
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-dbus_1.2.12.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Python bindings for the DBus inter-process communication system"
2SECTION = "devel/python"
3HOMEPAGE = "http://www.freedesktop.org/Software/dbus"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b03240518994df6d8c974675675e5ca4"
6DEPENDS = "expat dbus glib-2.0 virtual/libintl"
7
8SRC_URI = "http://dbus.freedesktop.org/releases/dbus-python/dbus-python-${PV}.tar.gz"
9
10SRC_URI[md5sum] = "428b7a9e7e2d154a7ceb3e13536283e4"
11SRC_URI[sha256sum] = "cdd4de2c4f5e58f287b12013ed7b41dee81d503c8d0d2397c5bd2fb01badf260"
12
13S = "${WORKDIR}/dbus-python-${PV}"
14
15inherit distutils3-base autotools pkgconfig
16
17# documentation needs python3-sphinx, which is not in oe-core or meta-python for now
18# change to use PACKAGECONFIG when python3-sphinx is added to oe-core
19EXTRA_OECONF += "--disable-documentation"
20
21
22RDEPENDS_${PN} = "python3-io python3-logging python3-stringold python3-threading python3-xml"
23
24FILES_${PN}-dev += "${libdir}/pkgconfig"
25
26BBCLASSEXTEND = "native nativesdk"