diff options
author | Alexander Kanavin <alex.kanavin@gmail.com> | 2022-03-08 10:32:17 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2022-03-09 11:46:27 +0000 |
commit | f2aeaa4848c9d334d56cb96a06a264b7274f9aa5 (patch) | |
tree | 7a3c48c4b66bc9ce25b6586e43c313003fc7f270 /meta/recipes-devtools/python/python3-cython_0.29.28.bb | |
parent | 0e3fc3399904684749857e40fb4ab89df579fb4b (diff) | |
download | poky-f2aeaa4848c9d334d56cb96a06a264b7274f9aa5.tar.gz |
python3-cython: upgrade 0.29.27 -> 0.29.28
(From OE-Core rev: 662333fbfa832cb6091b1bfdba8e218d288a8212)
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-cython_0.29.28.bb')
-rw-r--r-- | meta/recipes-devtools/python/python3-cython_0.29.28.bb | 37 |
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-cython_0.29.28.bb b/meta/recipes-devtools/python/python3-cython_0.29.28.bb new file mode 100644 index 0000000000..26333cb271 --- /dev/null +++ b/meta/recipes-devtools/python/python3-cython_0.29.28.bb | |||
@@ -0,0 +1,37 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-cython.inc | ||
3 | |||
4 | RDEPENDS:${PN} += "\ | ||
5 | python3-setuptools \ | ||
6 | " | ||
7 | |||
8 | # running build_ext a second time during install fails, because Python | ||
9 | # would then attempt to import cythonized modules built for the target | ||
10 | # architecture. | ||
11 | SETUPTOOLS_INSTALL_ARGS += "--skip-build" | ||
12 | |||
13 | do_install:append() { | ||
14 | # rename scripts that would conflict with the Python 2 build of Cython | ||
15 | mv ${D}${bindir}/cython ${D}${bindir}/cython3 | ||
16 | mv ${D}${bindir}/cythonize ${D}${bindir}/cythonize3 | ||
17 | mv ${D}${bindir}/cygdb ${D}${bindir}/cygdb3 | ||
18 | } | ||
19 | |||
20 | PACKAGEBUILDPKGD += "cython_fix_sources" | ||
21 | |||
22 | cython_fix_sources () { | ||
23 | for f in ${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/Cython-${PV}/Cython/Compiler/FlowControl.c \ | ||
24 | ${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/Cython-${PV}/Cython/Compiler/FusedNode.c \ | ||
25 | ${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/Cython-${PV}/Cython/Compiler/Scanning.c \ | ||
26 | ${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/Cython-${PV}/Cython/Compiler/Visitor.c \ | ||
27 | ${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/Cython-${PV}/Cython/Plex/Actions.c \ | ||
28 | ${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/Cython-${PV}/Cython/Plex/Scanners.c \ | ||
29 | ${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/Cython-${PV}/Cython/Runtime/refnanny.c \ | ||
30 | ${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/Cython-${PV}/Cython/Tempita/_tempita.c \ | ||
31 | ${PKGD}${libdir}/${PYTHON_DIR}/site-packages/Cython*/SOURCES.txt; do | ||
32 | if [ -e $f ]; then | ||
33 | sed -i -e 's#${WORKDIR}#/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}#g' $f | ||
34 | fi | ||
35 | done | ||
36 | } | ||
37 | |||