summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python3-asn1crypto_1.5.1.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2022-03-29 08:23:49 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-03-30 13:07:41 +0100
commit5215dd41bdb72ea385950285904f2479cebbd1fa (patch)
treeca737ead54b4d0a0c690e49fd7b43e4d573e07ba /meta/recipes-devtools/python/python3-asn1crypto_1.5.1.bb
parent6d668da03095db4a584d71c93319445f2806445a (diff)
downloadpoky-5215dd41bdb72ea385950285904f2479cebbd1fa.tar.gz
python3-asn1crypto: upgrade 1.4.0 -> 1.5.1
License-Update: year updated to 2022 Changelog: ========= - Handle RSASSA-PSS in keys.PrivateKeyInfo.bit_size and keys.PublicKeyInfo.bit_size - Handle RSASSA-PSS in keys.PrivateKeyInfo.wrap and keys.PublicKeyInfo.wrap - Updated docs for keys.PrivateKeyInfo.algorithm and keys.PublicKeyInfo.algorithm to reflect that they can return "rsassa_pss" (From OE-Core rev: 8fbe3bd4aca7a8906e342bcc9f27e205398919c3) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python3-asn1crypto_1.5.1.bb')
-rw-r--r--meta/recipes-devtools/python/python3-asn1crypto_1.5.1.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python3-asn1crypto_1.5.1.bb b/meta/recipes-devtools/python/python3-asn1crypto_1.5.1.bb
new file mode 100644
index 0000000000..5fa2ed987c
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-asn1crypto_1.5.1.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "A fast, pure Python library for parsing and serializing ASN.1 structures"
2HOMEPAGE = "https://github.com/wbond/asn1crypto"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b5cda97fbd7959ad47a952651a87051a"
6
7PYPI_PACKAGE = "asn1crypto"
8
9SRC_URI[sha256sum] = "13ae38502be632115abf8a24cbe5f4da52e3b5231990aff31123c805306ccb9c"
10
11inherit pypi setuptools3
12
13RDEPENDS:${PN}:class-target += " \
14 ${PYTHON_PN}-codecs \
15 ${PYTHON_PN}-crypt \
16 ${PYTHON_PN}-ctypes \
17 ${PYTHON_PN}-datetime \
18 ${PYTHON_PN}-io \
19 ${PYTHON_PN}-netclient \
20 ${PYTHON_PN}-numbers \
21 ${PYTHON_PN}-shell \
22"
23
24BBCLASSEXTEND = "native nativesdk"