diff options
author | Mark Hatle <mark.hatle@windriver.com> | 2012-12-11 08:09:40 -0600 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-12-17 17:24:52 +0000 |
commit | e1345b76c04b5a829b7219c12772bec1fb301850 (patch) | |
tree | 793cf4775df349af9db83230272ea6d7bcc8b840 /meta/recipes-devtools/python/python-smartpm_1.4.1.bb | |
parent | 8b671644e1fa5cb4e4d8b6b0dc26a4b08e7485b7 (diff) | |
download | poky-e1345b76c04b5a829b7219c12772bec1fb301850.tar.gz |
rpm/smart: Fix runtime-relocation issues w/ RPM and Smart
Fix runtime-relocation issues with the RPM and Smart wrappers.
In addition the patches were necessary to fix related problems.
The changes to the includes three categories of issues:
*) Incorrect pathname evaluations
*) Incorrect evaluation of the /etc/rpm/platform file contents
*) Confusing vendor #define checks
Finally, a simple way to debug the platformScore was added as
that is necessary to debug how this works and into the smart system.
(From OE-Core rev: 355a621caca66ed393d36fff6be8918921cf45ae)
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-smartpm_1.4.1.bb')
-rw-r--r-- | meta/recipes-devtools/python/python-smartpm_1.4.1.bb | 17 |
1 files changed, 16 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python-smartpm_1.4.1.bb b/meta/recipes-devtools/python/python-smartpm_1.4.1.bb index 53f232bfab..04f61f8999 100644 --- a/meta/recipes-devtools/python/python-smartpm_1.4.1.bb +++ b/meta/recipes-devtools/python/python-smartpm_1.4.1.bb | |||
@@ -11,7 +11,7 @@ LICENSE = "GPLv2" | |||
11 | LIC_FILES_CHKSUM = "file://LICENSE;md5=393a5ca445f6965873eca0259a17f833" | 11 | LIC_FILES_CHKSUM = "file://LICENSE;md5=393a5ca445f6965873eca0259a17f833" |
12 | 12 | ||
13 | DEPENDS = "python rpm" | 13 | DEPENDS = "python rpm" |
14 | PR = "r4" | 14 | PR = "r5" |
15 | SRCNAME = "smart" | 15 | SRCNAME = "smart" |
16 | 16 | ||
17 | SRC_URI = "\ | 17 | SRC_URI = "\ |
@@ -87,6 +87,21 @@ do_install_append() { | |||
87 | fi | 87 | fi |
88 | } | 88 | } |
89 | 89 | ||
90 | add_native_wrapper() { | ||
91 | create_wrapper ${D}/${bindir}/smart \ | ||
92 | RPM_USRLIBRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('libdir', True), d.getVar('bindir', True))}/rpm \ | ||
93 | RPM_ETCRPM='$'{RPM_ETCRPM-'`dirname $''realpath`'/${@os.path.relpath(d.getVar('sysconfdir', True), d.getVar('bindir', True))}/rpm} \ | ||
94 | RPM_LOCALEDIRRPM='`dirname $''realpath`'/${@os.path.relpath(d.getVar('datadir', True), d.getVar('bindir', True))}/locale | ||
95 | } | ||
96 | |||
97 | do_install_append_class-native() { | ||
98 | add_native_wrapper | ||
99 | } | ||
100 | |||
101 | do_install_append_class-nativesdk() { | ||
102 | add_native_wrapper | ||
103 | } | ||
104 | |||
90 | PACKAGES = "${PN}-dev ${PN}-dbg ${PN}-doc smartpm \ | 105 | PACKAGES = "${PN}-dev ${PN}-dbg ${PN}-doc smartpm \ |
91 | ${@base_contains('PACKAGECONFIG', 'rpm', '${PN}-backend-rpm', '', d)} \ | 106 | ${@base_contains('PACKAGECONFIG', 'rpm', '${PN}-backend-rpm', '', d)} \ |
92 | ${@base_contains('PACKAGECONFIG', 'qt4', '${PN}-interface-qt4', '', d)} \ | 107 | ${@base_contains('PACKAGECONFIG', 'qt4', '${PN}-interface-qt4', '', d)} \ |