summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-setuptools_36.2.7.bb
diff options
context:
space:
mode:
authorJose Lamego <jose.a.lamego@linux.intel.com>2017-08-09 15:01:04 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-16 00:03:14 +0100
commitb13df74256a9fce5991d09ab3916f96bedf9be2b (patch)
tree4d4284e1352349e977a87bb2fd0a3827d9133dfe /meta/recipes-devtools/python/python-setuptools_36.2.7.bb
parente31ba8f1228d30d41a6b83aa3cc07051e9ff3872 (diff)
downloadpoky-b13df74256a9fce5991d09ab3916f96bedf9be2b.tar.gz
python*-setuptools: update to 36.2.7
Both python-setuptools and python3-setuptools must be updated to latest stable release. These changes were tested on qemu with core-image-minimal (From OE-Core rev: 147d9260eb79edfdf7a91fb8bc3d915f141dc685) Signed-off-by: Jose Lamego <jose.a.lamego@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-setuptools_36.2.7.bb')
-rw-r--r--meta/recipes-devtools/python/python-setuptools_36.2.7.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-setuptools_36.2.7.bb b/meta/recipes-devtools/python/python-setuptools_36.2.7.bb
new file mode 100644
index 0000000000..526474c7ea
--- /dev/null
+++ b/meta/recipes-devtools/python/python-setuptools_36.2.7.bb
@@ -0,0 +1,38 @@
1require python-setuptools.inc
2
3PROVIDES = "python-distribute"
4
5DEPENDS += "python"
6DEPENDS_class-native += "python-native"
7
8inherit distutils
9
10DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}"
11
12RDEPENDS_${PN} = "\
13 python-stringold \
14 python-email \
15 python-shell \
16 python-distutils \
17 python-compression \
18 python-pkgutil \
19 python-plistlib \
20 python-numbers \
21 python-html \
22 python-netserver \
23 python-ctypes \
24 python-subprocess \
25 python-unittest \
26 python-compile \
27"
28
29RDEPENDS_${PN}_class-native = "\
30 python-distutils \
31 python-compression \
32"
33
34RREPLACES_${PN} = "python-distribute"
35RPROVIDES_${PN} = "python-distribute"
36RCONFLICTS_${PN} = "python-distribute"
37
38BBCLASSEXTEND = "native nativesdk"