summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-setuptools_32.1.1.bb
diff options
context:
space:
mode:
authorEdwin Plauchu <edwin.plauchu.camacho@linux.intel.com>2017-01-12 14:52:13 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-01-19 22:47:21 +0000
commitda76cda28f45f49b267c6f1b41df165914819d7f (patch)
tree1480b5f35692cd6e61573821153893da01ce6fc5 /meta/recipes-devtools/python/python-setuptools_32.1.1.bb
parentb0fc05ea492beddeb444efae8a49805bf1e926e0 (diff)
downloadpoky-da76cda28f45f49b267c6f1b41df165914819d7f.tar.gz
python3-setuptools: upgrade to 31.1.1
It is a simultaneous upgrade for python 2 and 3 over setuptools. (From OE-Core rev: e37e023da9833fc6d17a8a57554aaf986b4e8d56) Signed-off-by: Edwin Plauchu <edwin.plauchu.camacho@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-setuptools_32.1.1.bb')
-rw-r--r--meta/recipes-devtools/python/python-setuptools_32.1.1.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-setuptools_32.1.1.bb b/meta/recipes-devtools/python/python-setuptools_32.1.1.bb
new file mode 100644
index 0000000000..526474c7ea
--- /dev/null
+++ b/meta/recipes-devtools/python/python-setuptools_32.1.1.bb
@@ -0,0 +1,38 @@
1require python-setuptools.inc
2
3PROVIDES = "python-distribute"
4
5DEPENDS += "python"
6DEPENDS_class-native += "python-native"
7
8inherit distutils
9
10DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${PYTHON_SITEPACKAGES_DIR}"
11
12RDEPENDS_${PN} = "\
13 python-stringold \
14 python-email \
15 python-shell \
16 python-distutils \
17 python-compression \
18 python-pkgutil \
19 python-plistlib \
20 python-numbers \
21 python-html \
22 python-netserver \
23 python-ctypes \
24 python-subprocess \
25 python-unittest \
26 python-compile \
27"
28
29RDEPENDS_${PN}_class-native = "\
30 python-distutils \
31 python-compression \
32"
33
34RREPLACES_${PN} = "python-distribute"
35RPROVIDES_${PN} = "python-distribute"
36RCONFLICTS_${PN} = "python-distribute"
37
38BBCLASSEXTEND = "native nativesdk"