summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-setuptools_22.0.5.bb
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2016-06-08 05:56:08 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-12 23:47:16 +0100
commitf69acee1386ac0ba3e3b3b3a962e52a23d18521e (patch)
tree5000dc30861b48640fade67536c032f17919cf55 /meta/recipes-devtools/python/python-setuptools_22.0.5.bb
parent3411d2d466b86c9bc47a8ac41a0968eb17529ba2 (diff)
downloadpoky-f69acee1386ac0ba3e3b3b3a962e52a23d18521e.tar.gz
python-setuptools: Upgrade to 22.0.5
Source location changed on pypi, this must be changed on all other recipes as well, License also changed to MIT (From OE-Core rev: bb2ecb102f30d5165c4e47adadfe5d052c6a06ce) Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-setuptools_22.0.5.bb')
-rw-r--r--meta/recipes-devtools/python/python-setuptools_22.0.5.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-setuptools_22.0.5.bb b/meta/recipes-devtools/python/python-setuptools_22.0.5.bb
new file mode 100644
index 0000000000..c172039231
--- /dev/null
+++ b/meta/recipes-devtools/python/python-setuptools_22.0.5.bb
@@ -0,0 +1,38 @@
1require python-setuptools.inc
2
3PROVIDES = "python-distribute"
4
5DEPENDS += "python"
6DEPENDS_class-native += "python-native"
7
8inherit distutils
9
10DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages"
11
12RDEPENDS_${PN} = "\
13 python-stringold \
14 python-email \
15 python-shell \
16 python-distutils \
17 python-compression \
18 python-pkgutil \
19 python-plistlib \
20 python-numbers \
21 python-html \
22 python-netserver \
23 python-ctypes \
24 python-subprocess \
25 python-unittest \
26 python-compile \
27"
28
29RDEPENDS_${PN}_class-native = "\
30 python-distutils \
31 python-compression \
32"
33
34RREPLACES_${PN} = "python-distribute"
35RPROVIDES_${PN} = "python-distribute"
36RCONFLICTS_${PN} = "python-distribute"
37
38BBCLASSEXTEND = "native nativesdk"