summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-setuptools_19.2.bb
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2016-01-19 21:56:25 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-20 17:07:14 +0000
commit2a608cce9fec5fb840f1d355d3187619b6abdbf4 (patch)
tree75f5d8069a7e5627f100411b27a893aa979dbbc8 /meta/recipes-devtools/python/python-setuptools_19.2.bb
parent6395bc8328221d3a29f6598a7e2654e51b68e4e1 (diff)
downloadpoky-2a608cce9fec5fb840f1d355d3187619b6abdbf4.tar.gz
python-setuptools: Upgrade to 19.2
Upgrades python-setuptools to 19.2, easy_install works out of the box adds the package python-plistlib to the manifest as it is needed by setuptools now, and also updates runtime dependencies (From OE-Core rev: 25efefac9f68d34bbb109645a515010b846c3a8b) Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-setuptools_19.2.bb')
-rw-r--r--meta/recipes-devtools/python/python-setuptools_19.2.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-setuptools_19.2.bb b/meta/recipes-devtools/python/python-setuptools_19.2.bb
new file mode 100644
index 0000000000..404d301021
--- /dev/null
+++ b/meta/recipes-devtools/python/python-setuptools_19.2.bb
@@ -0,0 +1,55 @@
1SUMMARY = "Downloads, builds, installs, upgrades, and uninstalls Python packages"
2HOMEPAGE = "https://pypi.python.org/pypi/setuptools"
3SECTION = "devel/python"
4LICENSE = "Python-2.0 | ZPL-2.0"
5LIC_FILES_CHKSUM = "file://setup.py;beginline=78;endline=78;md5=8a314270dd7a8dbca741775415f1716e"
6
7SRCNAME = "setuptools"
8
9PROVIDES = "python-distribute"
10
11DEPENDS += "python"
12DEPENDS_class-native += "python-native"
13
14inherit distutils
15
16SRC_URI = "https://pypi.python.org/packages/source/s/setuptools/setuptools-${PV}.tar.gz"
17SRC_URI[md5sum] = "78353b1f80375ca5e088f4b4627ffe03"
18SRC_URI[sha256sum] = "f90ed8eb70b14b0594ba74e9de4ffca040c0ec8ee505cbf3570499467859f71a"
19UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/setuptools"
20
21S = "${WORKDIR}/${SRCNAME}-${PV}"
22
23
24DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages"
25
26do_install_prepend() {
27 install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
28}
29
30RDEPENDS_${PN} = "\
31 python-stringold \
32 python-email \
33 python-shell \
34 python-distutils \
35 python-compression \
36 python-pkgutil \
37 python-plistlib \
38 python-numbers \
39 python-html \
40 python-netserver \
41 python-ctypes \
42 python-subprocess \
43 python-unittest \
44"
45
46RDEPENDS_${PN}_class-native = "\
47 python-distutils \
48 python-compression \
49"
50
51RREPLACES_${PN} = "python-distribute"
52RPROVIDES_${PN} = "python-distribute"
53RCONFLICTS_${PN} = "python-distribute"
54
55BBCLASSEXTEND = "native nativesdk"