summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-scons_3.0.1.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-11-18 18:28:56 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-13 14:00:52 +0000
commitb73e96e7f3f5d1ba3a221d99792a7a3c7ef42c21 (patch)
tree26511020befbc8d0f54de1c031d80b21563fa35b /meta/recipes-devtools/python/python-scons_3.0.1.bb
parent9f8525721672577cbaab96081094211479db4c76 (diff)
downloadpoky-b73e96e7f3f5d1ba3a221d99792a7a3c7ef42c21.tar.gz
python-scons: upgrade to v3.0.1; use pypi.bbclass
* Simplify recipe by using pypi.bbclass * Drop patch for __future__ print_function - fixed upstream: https://github.com/SConsProject/scons/pull/1/commits/4c199d06e76afb9379e76942d0f68caa57f42509 (From OE-Core rev: cf5c44ac611c2c2657e6fd3c1f723bcb20b812dd) Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-scons_3.0.1.bb')
-rw-r--r--meta/recipes-devtools/python/python-scons_3.0.1.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-scons_3.0.1.bb b/meta/recipes-devtools/python/python-scons_3.0.1.bb
new file mode 100644
index 0000000000..2f75b08d25
--- /dev/null
+++ b/meta/recipes-devtools/python/python-scons_3.0.1.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Software Construction tool (make/autotools replacement)"
2SECTION = "devel/python"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=46ddf66004e5be5566367cb525a66fc6"
5
6SRC_URI[md5sum] = "b6a292e251b34b82c203b56cfa3968b3"
7SRC_URI[sha256sum] = "24475e38d39c19683bc88054524df018fe6949d70fbd4c69e298d39a0269f173"
8
9UPSTREAM_CHECK_URI = "http://scons.org/pages/download.html"
10UPSTREAM_CHECK_REGEX = "(?P<pver>\d+(\.\d+)+)\.tar"
11
12inherit pypi setuptools
13
14RDEPENDS_${PN} = "\
15 python-fcntl \
16 python-io \
17 python-json \
18 python-subprocess \
19 python-shell \
20 python-pprint \
21 python-importlib \
22 "