summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-scons_3.0.0.bb
diff options
context:
space:
mode:
authorJose Lamego <jose.a.lamego@linux.intel.com>2017-10-19 14:28:25 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-05 22:33:22 +0000
commitb55218a024f2b529ccbe0e321228b9595ce67b51 (patch)
tree5b8fb85c448cf91610bd2687e12c7778682c0f4a /meta/recipes-devtools/python/python-scons_3.0.0.bb
parentb063b982a4b1d1a28cc35ff9b60bb6b310fe344a (diff)
downloadpoky-b55218a024f2b529ccbe0e321228b9595ce67b51.tar.gz
python-scons*: upgrade to 3.0.0
Both python-scons and python-scons-native need to be upgraded to latest upstream version. LIC_FILES_CHKSUM changed due to updated year in date, but rest of file remain the same. Following dependencies were added to enable appropriate package usage: python-shell, python-pprint and python-importlib. A patch was taken from upstream to support python2 print statements in SConscripts. This should be included in next version. These changes were tested in qemux86 with core-image-minimal. (From OE-Core rev: 4fe7774f08ba46bd1d68e56eff3f4912db107c25) Signed-off-by: Jose Lamego <jose.a.lamego@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-scons_3.0.0.bb')
-rw-r--r--meta/recipes-devtools/python/python-scons_3.0.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-scons_3.0.0.bb b/meta/recipes-devtools/python/python-scons_3.0.0.bb
new file mode 100644
index 0000000000..33bfb45e2e
--- /dev/null
+++ b/meta/recipes-devtools/python/python-scons_3.0.0.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Software Construction tool (make/autotools replacement)"
2SECTION = "devel/python"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=46ddf66004e5be5566367cb525a66fc6"
5SRCNAME = "scons"
6
7SRC_URI = "https://files.pythonhosted.org/packages/source/s/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \
8 file://SConscript-Support-python2-print-statements.patch"
9
10SRC_URI[md5sum] = "7ca558edaaa1942fe38f3105ca2400fb"
11SRC_URI[sha256sum] = "aa5afb33c2bbd33c311e47e912412195739e9ffb2e933534a31f85fba8f3470e"
12
13UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/SCons/"
14
15S = "${WORKDIR}/${SRCNAME}-${PV}"
16
17inherit setuptools
18
19RDEPENDS_${PN} = "\
20 python-fcntl \
21 python-io \
22 python-json \
23 python-subprocess \
24 python-shell \
25 python-pprint \
26 python-importlib \
27 "