summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-scons_2.5.1.bb
diff options
context:
space:
mode:
authorJose Lamego <jose.a.lamego@linux.intel.com>2016-11-16 15:22:16 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-23 11:10:15 +0000
commit8670100bae0ae393c1c1b63cddc08c52c062dfe5 (patch)
treea9533f32c11b0d4f1364dcb685522c7b6dbc4fd8 /meta/recipes-devtools/python/python-scons_2.5.1.bb
parent0bfefc3ba53bd42c4fc843af1bc79a7a2c7ef742 (diff)
downloadpoky-8670100bae0ae393c1c1b63cddc08c52c062dfe5.tar.gz
python-scons*: upgrade to 2.5.1
Both python-scons and python-scons-native need to be upgraded to latest upstream version. This change was tested using qemux86 with core-image-sato. (From OE-Core rev: b3dc1eb3baf54a313a9de03700d57f592bbd73b8) Signed-off-by: Jose Lamego <jose.a.lamego@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-scons_2.5.1.bb')
-rw-r--r--meta/recipes-devtools/python/python-scons_2.5.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-scons_2.5.1.bb b/meta/recipes-devtools/python/python-scons_2.5.1.bb
new file mode 100644
index 0000000000..3f43856199
--- /dev/null
+++ b/meta/recipes-devtools/python/python-scons_2.5.1.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Software Construction tool (make/autotools replacement)"
2SECTION = "devel/python"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3a885dff6d14e4cd876d9008a09a42de"
5SRCNAME = "scons"
6
7SRC_URI = "https://files.pythonhosted.org/packages/source/s/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
8
9SRC_URI[md5sum] = "3eac81e5e8206304a9b4683c57665aa4"
10SRC_URI[sha256sum] = "c8de85fc02ed1a687b1f2ac791eaa0c1707b4382a204f17d782b5b111b9fdf07"
11
12UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/SCons/"
13
14S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16inherit setuptools
17
18RDEPENDS_${PN} = "\
19 python-fcntl \
20 python-io \
21 python-json \
22 python-subprocess \
23 "