diff options
author | Gary Thomas <gary@mlbassoc.com> | 2014-11-05 07:57:38 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2014-11-09 10:21:24 +0000 |
commit | 77d62cca2723c85bed0a6ac936948bceb81e9f11 (patch) | |
tree | 307be522bf5eb446843d4105d4de8a24c8d51fa0 /meta/recipes-devtools/python/python-pygtk_2.24.0.bb | |
parent | fb4d7ece3b5e67bcab133e8d6f17d2257d04049e (diff) | |
download | poky-77d62cca2723c85bed0a6ac936948bceb81e9f11.tar.gz |
python-pygtk: Clean up incorrect "fix"
This patch removes most of "dirty fix #1" which is no longer needed
(no dependency on python-pygobject-dev exists). A side effect is
that the pygtk code generator will also be installed.
Merge 'fix-path.inc' into this recipe as it is not used by any other
recipe.
(From OE-Core rev: 02985d315f71126d3af789b0666dbf428f586e4b)
Signed-off-by: Gary Thomas <gary@mlbassoc.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-pygtk_2.24.0.bb')
-rw-r--r-- | meta/recipes-devtools/python/python-pygtk_2.24.0.bb | 27 |
1 files changed, 21 insertions, 6 deletions
diff --git a/meta/recipes-devtools/python/python-pygtk_2.24.0.bb b/meta/recipes-devtools/python/python-pygtk_2.24.0.bb index bd26ebb7da..053f37fcbe 100644 --- a/meta/recipes-devtools/python/python-pygtk_2.24.0.bb +++ b/meta/recipes-devtools/python/python-pygtk_2.24.0.bb | |||
@@ -40,16 +40,31 @@ do_configure_prepend() { | |||
40 | sed -i 's:tests docs:tests:' ${S}/Makefile.am | 40 | sed -i 's:tests docs:tests:' ${S}/Makefile.am |
41 | } | 41 | } |
42 | 42 | ||
43 | # dirty fix #1: remove dependency on python-pygobject-dev | 43 | # dirty fix #2: fix build system paths leaking in |
44 | do_install_append() { | 44 | do_install_append() { |
45 | find ${D} -name "*.la"|xargs rm -f | 45 | for i in `find ${D} -name "*.py"` ; do \ |
46 | rm -f ${D}/${bindir}/pygtk-codegen-2.0 | 46 | sed -i -e s:${D}::g $i |
47 | done | ||
48 | |||
49 | for i in `find ${D} -name "*.la"` ; do \ | ||
50 | sed -i -e s:${STAGING_LIBDIR}:${libdir}:g $i | ||
51 | done | ||
52 | |||
53 | if test -e ${D}${bindir} ; then | ||
54 | for i in ${D}${bindir}/* ; do \ | ||
55 | sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g $i | ||
56 | done | ||
57 | fi | ||
58 | |||
59 | if test -e ${D}${sbindir} ; then | ||
60 | for i in ${D}${sbindir}/* ; do \ | ||
61 | sed -i -e s:${STAGING_BINDIR_NATIVE}:${bindir}:g $i | ||
62 | done | ||
63 | fi | ||
64 | |||
47 | sed -i -e '1s|^#!.*python|#!/usr/bin/env python|' ${D}${bindir}/pygtk-demo | 65 | sed -i -e '1s|^#!.*python|#!/usr/bin/env python|' ${D}${bindir}/pygtk-demo |
48 | } | 66 | } |
49 | 67 | ||
50 | # dirty fix #2: fix build system paths leaking in | ||
51 | require fix-path.inc | ||
52 | |||
53 | PACKAGES =+ "${PN}-demo" | 68 | PACKAGES =+ "${PN}-demo" |
54 | FILES_${PN}-demo = " ${bindir}/pygtk-demo ${libdir}/pygtk " | 69 | FILES_${PN}-demo = " ${bindir}/pygtk-demo ${libdir}/pygtk " |
55 | RDEPENDS_${PN}-demo = "python-pygtk python-stringold python-lang" | 70 | RDEPENDS_${PN}-demo = "python-pygtk python-stringold python-lang" |