summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-pygtk_2.17.0.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-devtools/python/python-pygtk_2.17.0.bb
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadpoky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/python/python-pygtk_2.17.0.bb')
-rw-r--r--meta/recipes-devtools/python/python-pygtk_2.17.0.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-pygtk_2.17.0.bb b/meta/recipes-devtools/python/python-pygtk_2.17.0.bb
new file mode 100644
index 0000000000..ef63b51038
--- /dev/null
+++ b/meta/recipes-devtools/python/python-pygtk_2.17.0.bb
@@ -0,0 +1,42 @@
1DESCRIPTION = "Python GTK+ 2.17.x Bindings"
2SECTION = "devel/python"
3# needs gtk+ 2.17.x
4DEPENDS = "gtk+ libglade python-pycairo python-pygobject"
5RDEPENDS = "python-shell python-pycairo python-pygobject"
6PROVIDES = "python-pygtk2"
7SRCNAME = "pygtk"
8LICENSE = "LGPL"
9PR = "ml8.2"
10
11SRC_URI = "ftp://ftp.gnome.org/pub/gnome/sources/pygtk/2.17/${SRCNAME}-${PV}.tar.bz2 \
12 file://fix-gtkunixprint.patch \
13 file://prevent_to_get_display_during_import.patch \
14 file://nodocs.patch \
15 file://acinclude.m4"
16S = "${WORKDIR}/${SRCNAME}-${PV}"
17
18EXTRA_OECONF = "--disable-docs --with-python-includes=${STAGING_INCDIR}/../"
19
20inherit autotools pkgconfig distutils-base
21
22do_configure_prepend() {
23 install -m 0644 ${WORKDIR}/acinclude.m4 ${S}/
24}
25
26# dirty fix #1: remove dependency on python-pygobject-dev
27do_install_append() {
28 find ${D} -name "*.la"|xargs rm -f
29 rm -f ${D}/${bindir}/pygtk-codegen-2.0
30 rm -rf ${D}/${libdir}/pkgconfig
31}
32
33# dirty fix #2: fix build system paths leaking in
34require fix-path.inc
35
36PACKAGES =+ "${PN}-demo"
37FILES_${PN}-demo = " ${bindir}/pygtk-demo ${libdir}/pygtk "
38RDEPENDS_${PN}-demo = "python-pygtk python-stringold python-lang"
39
40# todo: revamp packaging, package demo seperatly
41FILES_${PN}-dev += " ${libdir}/pygtk/2.0 ${bindir}/pygtk-* ${datadir}/pygtk/2.0"
42